Download failed unknown error

I first noticed this behavior yesterday. The only file that had changed yesterday was a note in my QOwnNotes which stores all of its notes in /Notes in my profile. I experimented with removing that note file and replacing it to see if that was the cause. The file could not be downloaded to be viewed, but other Notes worked. I uninstalled and reinstalled the Android app while troubleshooting, and now no files will download, though they are all visible in the folder hierarchy.

Actual behaviour

  • ownCloud Android up pops up an uninformative notification stating “Download failed unknown error”

Expected behaviour

  • Notification should explain what download failed and if possible why it failed

Steps to reproduce

  1. Clear error notification
  2. Wait
  3. Notification returns

Can this problem be reproduced with the official owncloud server?
(url: https://demo.owncloud.org, user: test, password: test)

Environment data

Android version: 14

Device model: Samsung Glaxy S22 Ultra

Stock or customized system: Stock

ownCloud app version: 4.2.1

ownCloud server version: 10.14.0 installed on Debian Bookworm from official ownCloud apt repo

Logs

Web server error log

webserver error log contained nothing related to ownCloud

ownCloud log (data/owncloud.log)

This file is currently at 148 extremely long lines. Trying to find the relevant linesis cumbersome due to the amount of garbage that is logged by broken old code that has never been cleaned up. (See issue #34524 for one such example that is polluting this log file.)

Does anyone have any ideas on how to effeciently troubleshoot this issue?

same Problem …

All other clients are working - did upgrade the owncloud server to http2 - Mediafiles can be played like mpgs but no files can be downloaded - Download failed…

1 Like

The F-Droid Android app hasn’t been updated since February, and I haven’t seen any updates to ownCloud 10 that align with or near the date that I noticed this, so I am a little lost for where to begin listing possible causes for a proper 5 step troubleshooting.

I’ve uninstalled the Android app for now, since it doesn’t currently seem to do anything besides repeat that notification. If there are some testing ideas, I can reinstall.

Hi, same problem with Android phones.

2 Likes

Hey,

if the other two accounts are no spam bots (in the last two days multiple spam bots had posted here at the same time) but real users (one had posted 7 years ago according to a banner shown to me):

I think if this started to happen recently (i think this could be possible if now two other users are just posting “Have the same problem” without giving much details) then i think that it could maybe make sense to notify the ownCloud android app developers about a possible recently introduced problem over at the GitHub issue tracker of the Android app.

1 Like

Thanks all for reporting. We have the following issue, in which there are some suspictions about backend to be involved: [BUG] Text (.txt) file won't download / open in Android App · Issue #4352 · owncloud/android · GitHub

1 Like

I also use only php-fpm instances and had the same problem. by adding the line SetEnv ap_trust_cgilike_cl to the .htaccess file, my problem was solved.

This worked for me!!!

1 Like

Here you have a potentially solution:

anyway, we’ll try to figure out why is this happening because Android app’s downloads did not have changes in the last released version.

1 Like

Same problem here since Mid April. No changes were made to the App or any user settings. No changes were made on the server side. Also downloaded the latest version of the ownCloud app from Google PlayStore.4.2.1 (a41d1f917).

Whereas the directory structure and the file names are visible in the App, any download, regardless of file type or file size, fails with the “an unknown error occurrred” message.

Environment data

Android version: 14 UKQ1.23804.001
Device model: Xiaomi 13, Xiaomi HyperOS 1.0.3.0 UMCEUXM

also resolved this for me.