Dropbox v2 integration not working

10

#1

Hi there,

I just upgraded to ownCloud 10.x and installed the new app for Dropbox API v2 support.

I followed the instructions to set the whole thing up, but the "grant access" button does nothing and the little square on the left-hand side stays red - pretty much the exact same problem as described in the comments here.

Technically, if you check https://github.com/Hemant-Mann/files_external_dropbox/blob/master/lib/Storage/Dropbox.php you'll see the constructor expects a configured parameter to be set to 'true', which isn't the case.

Please let me know if you need any extra info. Thanks!


#2

Hello!
It did not work for me.
By entering the correct Dropbox API data and then clicking the "Allow Access" button I'm redirected to the Dropbox page to authorize access. After allowing access when returning to the Owncloud installation the square remains red.


#3

Same Problem here, click on Grant Access and redirection does not work....


#4

Same here. Really hoping there is an update to this. I wonder if anyone has it working?


#5

Hey there,

You need to make sure that you select the correct External Storage (it shows OAuth2 as authentication mechanism)

Make sure you use the correct url for the callback

As Global Mounted storage:
<path to your ownclod>/index.php/settings/admin?sectionid=storage

As User
<path to your ownclod>/index.php/settings/personal?sectionid=storage


#6

Last but not least important, please ensure that you copy+pase the app/client credentials correctly (no extra spaces)

See this screenshot how to fill in the details


#7

Yes. I triple-checked all that. It does not work for me. I gave you technical details regarding the exact spot in code where the error occurs.


#8

I also have this issue despite all the settings being correct and triple triple checked and checked a few more times just to be sure.


#9

opened an issue: https://github.com/owncloud/files_external_dropbox/issues/13


#10

Well, maybe I am doing something wrong, down to the basics (and for whom does not have english as his primary language), for "path to your ownclod" We can assume that it is the FQDN of the server right? Is there any problem if the server is behind NAT and using an external port other tan 443 and redirecting it throught NAT?


#11

I don't think there should be any issue with that, as long as that redirect url is reachable from the client/pc where you are performing the oauth flow.

For example, I am issuing the request against my local test instance and have this url in dropbox:
http://localhost:9080/owncloud/index.php/settings/admin?sectionid=storage

Note:
localhost is a special url for dropbox and allows for using http. When using a different FQDN than localhost, dropbox requires https. So whatever your port number is, it must be the ssl terminated endpoint of your server


#12

I'm using CloudFlare for HTTPS, now that I think about it. Could that be an issue?


#13

I got it
Instead of copying and pasting the data as I was doing before I typed the data, and allowing access on the Dropbox screen all right.


#14

I am not quite sure - if you can test with a different instance or with a quick setup via localhost (docker?) that can confirm

I have tried to reproduce the mentioned issue here for quite some time and I noticed that sometimes during c+p from the dropbox website, extra spaces are copied/created.
That's the reason why I mentioned to ensure that when copy+pasting no extra characters are copied.


#15

Finished well. However I found loading the files very slow. I do not know if Dropbox or my connection


#16

Tried everything, copy & paste, typing, nothing, strange thing is the Oauth1 does something but as it was shut down it gives me an error

Don´t know if will help.....

POST https://192.168.0.254:22443/index.php/apps/files_external/globalstorages 422 (Unprocessable Entity) jquery.js:8630
send @ jquery.js:8630
ajax @ jquery.js:8166
save @ settings.js?v=8c50e68…:277
saveStorageConfig @ settings.js?v=8c50e68…:1148
(anonymous) @ settings.js?v=8c50e68…:747
setTimeout (async)
_onChange @ settings.js?v=8c50e68…:746
dispatch @ jquery.js:4435
r.handle @ jquery.js:4121


#17

The API does not give fastest access I fear, if there are ways to optimize by anybody - certainly welcome!


#18

Manually entering the "Redirect URI", solved it for me.
Had to press Grant Access twice to get OC to show the green square.

It works - kinda' - but the connection is very slow.
Is this a problem with Owncloud or Dropbox?


#19

I spoketh too soon.
I'm having serious sync-problems with the desktop client on my CentOS7-machine.
Also httpd seems to crash on the OC-server (running CentOS6), requiring a daemon restart.
I'm disabling the Dropbox app for now.


#20

Could you create a ticket at https://github.com/owncloud/files_external_dropbox and provide some more information on your setup (owncloud version; owncloud log etc)

Thanks