E-Mail Server SMTP Configuration - 550 Relay Error


#1

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release:
Steps to reproduce
1. Changing The SMTP Settings from One E-Mail Server to Another
2.
3.

Expected behaviour
E-mail Notifications should work like they do now

Actual behaviour
550 Relay Not Permitted error while sending the test mail

Exact Error : Log data:>> MAIL FROM: owncloud@DOMAINNAME.com< 250 OK>> RCPT TO: <emailaddress@anotherDOMAINNAME.de<< 550 Relay not permitted !! Expected response code 250/251/252 but got code "550", with message "550 Relay not permitted

Server configuration
Operating system: ubuntu server 14.04 LTS
Web server: Apache2
Database: mySQL 14.14
PHP version: 5.5.9
ownCloud version (see ownCloud admin page): 9.0.1
Updated from an older ownCloud or fresh install: fresh
ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808):

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):
no

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.
No errors have been found.

#2

with my old smtp settings it works fine. just when i switch it... where should i check ?? i dont have a plan anymore

if you need any more infos pls just ask.


#3

Hi,

this is obviously an issue on the smtp server configuration.

Please throw this "relay access denied" message into your favorite search engine to get the first basic info about this message and the reasons why this appear.


#4

If the old settings work, i'd recommend you stay with the old settings.

FYI relay access denied means exactly that - your SMTP server is not allowing your host to relay mail through it. Add the sending host to the /etc/mail/relay-domains file if you're using sendmail. If you're using Postfix, or some other MTA, then RTFM to see where you have to make the change.


#5

got it fixed. it was a problem with the sophos i think..

but now i dont get any email notifications. the cron jobs are running with ajax (didnt work yesterday the whole day.) The cronjob is running perfectly but it just doesnt send any mails.
and now i tried to switch it to cron. maybe that will help but i dont know.

a local cronjob did solve the problem. i have no clue why ajax didnt work.


#6

Could be a mail server issue as well. Check the logfiles of owncloud and your mailserver.


#7

Please create a new thread for this new issue: