Email in 9.1 not working for non server domains

help

#1

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

Steps to reproduce
1. Share a file
2. Emter email address (not a local server domain)
3. Get Error that email cannot be sent.

(Yet, email to server email domains do work from OwnCloud link sharing.)

Expected behaviour

Email should go to notify user about shared link.

Actual behaviour

Error that Email cannot be sent.

Yet local email domains work OK. The email is sent in this case.

Server configuration
Operating system: Linux
Web server: Apache
Database: MySQL
PHP version:
ownCloud version (see ownCloud admin page):
Updated from an older ownCloud or fresh install:
ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808):

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

Integrity status for oC9+

Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results

  • core
    • INVALID_HASH
      • core/doc/admin/_static/style.css
      • core/vendor/jquery-migrate/jquery-migrate.js
      • core/vendor/jquery-migrate/jquery-migrate.min.js
  • files_external
    • INVALID_HASH
      • 3rdparty/Dropbox/API.php
  • files_texteditor
    • INVALID_HASH
      • js/vendor/ace/src-noconflict/mode-diff.js

Raw output

Array
(
[core] => Array
(
[INVALID_HASH] => Array
(
[core/doc/admin/_static/style.css] => Array
(
[expected] => 894b1bea3e2b6bc61824ffebc081339a6caf0b57cda7fa9b9c9a5965e2a165dc177055db176cb535ef465c927b4bc4848802fe3e1b0fb709194b3cb7d2f90f8d
[current] => 5d9fbe71f0eae36c5a9c50f98733cc9e7a5bc7b2b56e3937c4431cf5e54649667bbe8f5900cdcbfbaa8b1eb8d5476d42a278d210c38110411885ad818e3a963a
)

                [core/vendor/jquery-migrate/jquery-migrate.js] => Array
                    (
                        [expected] => 083c7aaf7b7304b2610ed5ff851f840d5db24993814128b86f42e8e5749b76e7117f6f154a8465fb4f163c1105ec3c6a5757e9c48b95e869d101de9399780a0e
                        [current] => 82955f5ce43d463443b9dc244923aeb5e2808bd5c93a17fa93a014b577b05cfa7f4f3ddee3f405721a57a2825f6ccebbb4c0a6c2f4557ba5bf396d525bb21fd8
                    )

                [core/vendor/jquery-migrate/jquery-migrate.min.js] => Array
                    (
                        [expected] => 7c31817254b71d4cac10120aa2829614311658e468036d27eb43b063b392620c4611ec3db3b3600da3e48fb82a41c5579c048fbd9022156f038b2b6cb5d946b5
                        [current] => 90638fea018fd8d678086a2862795d2bd50f76f2d9c58eec5ca9ba29e63596738a82c37b24cf4373b57a97fe13c68bcdfc92aabcc706c99ed46c69785e69adb7
                    )

            )

    )

[files_external] => Array
    (
        [INVALID_HASH] => Array
            (
                [3rdparty/Dropbox/API.php] => Array
                    (
                        [expected] => a6866ef3ceeb26d9d4b2ccc343aeaf626c82f03e279962bc7d761a68e87e5a7916ff0bcf7a350e20889557336ed9c5dd1651cfe513fa04bb8a03cd6d8f9cc484
                        [current] => 917eed2c4f6359a4d0b8658a36404c83344b0bf72ccda614dd59f97d099b3d9ef4e86691401c64d3754c3f7e0fa163eab946a25dbc7bc65e1694ffd47a054317
                    )

            )

    )

[files_texteditor] => Array
    (
        [INVALID_HASH] => Array
            (
                [js/vendor/ace/src-noconflict/mode-diff.js] => Array
                    (
                        [expected] => 4a59b6376376b81e4e12ccc345065db62029a61035a88e19b1be3d7ec4cd9f86444121cca6d46c44a5f86e4f5b44d5109cbc77e80c07ff8dbce61f758b88e765
                        [current] => 298cba4d3b472b418aca47db6522c752a4b5530de3f6f2d83eb42eb5fe4231356bfd860a7e2f735b3e5ced759dbc6ca26fc6a18c49bd7ffa07d5a6faa78ae51d
                    )

            )

    )

)


#2

How have you configured notification mails to be sent? Via php/smtp/..? Check also your webserver-logfiles and mailserver (if you use your own).


#3

Excellent suggestions!

Wow, thanks very much.

Turned out under authentication in email, I didn't have the full email account which is required to authenticate on my server. Apparently that's enough for an email account on the server but not for email outside the domain.

The actual error in the email log was to "Please turn on SMTP Authentication in your mail client".

Thanks again! It's working!!!! :smile: