Email Notification - http://localhost


#1

Hi,

Mail notifications are coming in with http://localhost instead of my url

You are receiving this email because the following things happened at http://localhost/

wondering where that is configured?

is that is changed in config.php?

found this in the mail notification template:

print_unescaped($l->t('You are receiving this email because the following things happened at %s', array($_['owncloud_installation'])));

but not sure where to set owncloud_installation

Any help is appreciated.

Server configuration
Operating system: Ubuntu 14.04.5 LTS (GNU/Linux 3.13.0-107-generic x86_64)
Web server: Apache
Database: Mysql
PHP version: PHP 5.5.9-1ubuntu4.20 (cli) (built: Oct 3 2016 13:00:37)
ownCloud version (see ownCloud admin page): ownCloud 9.1.3 (stable)


#2

tried changing
from:
'overwrite.cli.url' => 'http://localhost',
to:
'overwrite.cli.url' => 'http://owncloud.mycompany.com/',


#3

Yes, this is the correct place to configure this.


#4

worked!

not sure why it takes approx 30 minutes for email to be sent, but when it arrived it was showing correct url


#5

See your personal settings, activity e-mails are only sent out once an hour as a default. Adding to this they might be even more delayed if you're using the default (and not recommended) AJAX background jobs method.


#6

1 hour is not a problem

Im using cron

thanks