Email notification wrong timezone owncloud 9.1.6.2 stable


#1

Steps to reproduce

  1. upload new file
  2. notification mail setup
  3. look at email -> not Berlin/Brussels timezone

Expected behaviour

Tell us what should happen
correct time should be shown

Actual behaviour

Tell us what happens instead
wrong timezone

Server configuration

Operating system:
Ubuntu 16.04 LTS

Web server:
Apache

Database:
MariaDB

PHP version:
PHP 7.0.18-0ubuntu0.16.04.1

ownCloud version: (see ownCloud admin page)
9.1.6 stable

Updated from an older ownCloud or fresh install:
updated since Version 6

Where did you install ownCloud from:
website gz-download not with apt

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

No errors have been found.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/...

Are you using encryption: yes/no
SSL yes, user data encryption NO

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/...
NO

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

#2

Have a look at your php.ini, there you should be able to configure your timezone via some paramters / options.


#3

Hi,

I have the same problem, and time zone is set in my php.ini and php display time is correctly.


#4

this might be of interest for you: