Enable sharing is grayed out for SMB share

Enable sharing is grayed out for SMB share
Dear friends, I have an issue “Enable sharing” checkbox is grayed out for SMB share.
When I use local share - “Enable sharing” is active.
Is there any option to enalble sharing for SMB external storage mounts (Authentication type: login credentials, save in session)?
I attached my screenshot.

Steps to reproduce

  1. Connect SMB share with autentication (Authentication type: login credentials, save in session)as a external storage.
  2. Try to enable “Enable sharing” checkbox

Expected behaviour

“Enable sharing” checkbox is active

Actual behaviour

“Enable sharing” checkbox is grayed out for SMB share

Server configuration

Operating system:
OMV6 (debian 11)

Web server:
Apache (default)

Database:
MySQL

PHP version:
ownCloud 10.11.0 (stable) standard docker installation, idk how to check php version

ownCloud version: (see ownCloud admin page)
ownCloud 10.11.0 (stable)

Updated from an older ownCloud or fresh install:
fresh install

Where did you install ownCloud from:
official docker yml file

Signing status (ownCloud 9.0 and above):
Idk how to check

In integrity check: No errors have been found.

The content of config/config.php:

<?php $CONFIG = array ( 'apps_paths' => array ( 0 => array ( 'path' => '/var/www/owncloud/apps', 'url' => '/apps', 'writable' => false, ), 1 => array ( 'path' => '/var/www/owncloud/custom', 'url' => '/custom', 'writable' => true, ), ), 'trusted_domains' => array ( 0 => 'localhost', ), 'datadirectory' => '/mnt/data/files', 'dbtype' => 'mypass', 'dbhost' => 'mariadb:3306', 'dbname' => 'mypass', 'dbuser' => 'mypass', 'dbpassword' => 'mypass', 'dbtableprefix' => 'oc_', 'log_type' => 'mypass', 'supportedDatabases' => array ( 0 => 'sqlite', 1 => 'mysql', 2 => 'pgsql', ), 'upgrade.disable-web' => true, 'default_language' => 'en', 'overwrite.cli.url' => 'mylocalhost:8080', 'overwritehost' => 'mypublickdns:8888', 'session_keepalive' => true, 'has_internet_connection' => true, 'htaccess.RewriteBase' => '/', 'logfile' => '/mnt/data/files/owncloud.log', 'memcache.local' => '\\OC\\Memcache\\APCu', 'mysql.utf8mb4' => true, 'filelocking.enabled' => true, 'memcache.distributed' => '\\OC\\Memcache\\Redis', 'memcache.locking' => '\\OC\\Memcache\\Redis', 'redis' => array ( 'host' => 'redis', 'port' => '6379', ), 'passwordsalt' => 'mypasswordsalt', 'secret' => 'mysecret', 'version' => '10.11.0.6', 'allow_user_to_change_mail_address' => '', 'logtimezone' => 'UTC', 'installed' => true, 'instanceid' => 'ockv9qgkspra', 'files_external_allow_create_new_local' => 'true', ) ; **List of activated apps:** I have default set of activated apps via official docker installation ``` **Are you using external storage, if yes which one:** local/smb/sftp/... local and smb **Are you using an external user-backend, if yes which one:** LDAP/ActiveDirectory/Webdav/... ### Client configuration any **Operating system:** any ### Logs #### Web server error log ``` don't know hot to find but probably not applicable ``` #### ownCloud log (data/owncloud.log) ``` Insert your ownCloud log here ```

That’s the intended behavior. It isn’t possible to share files using “saved in session” credentials.

If user1 shares with user2, we’d need the user1’s credentials in order to access to the share. User2 can’t access to those credentials if they’re saved in user1’s session.

1 Like

Thank you very much Sir!
But actually it’s not very convenient I guess : )
It seems quite OK to be able to save specific password from SMB share and use it for all users :slight_smile: But of course it’s not a big problem : )
Thanx a lot! :dizzy: