Encryption - EC2

Steps to reproduce

  1. In an EC2 t2.micro or t2.medium instance (I’ve tried both), enable encryption with the default module, master key. This can be done either through occ or the GUI (the result has been the same).
  2. Once enabled, log out as the web GUI instructs.
  3. Log back in. This may or may not work.
  4. Eventually, the entire instance is hung and you can’t even SSH to the system.

Expected behaviour

Encryption should be enabled and the site still accessible.

Actual behaviour

The entire EC2 instance is locked up and inaccessible.

Server configuration

Operating system: Ubuntu Linux 18.04

Web server: Apache (latest available in 18.04 repos)

Database: MariaDB (latest available in 18.04 repos)

PHP version: 7.4

ownCloud version: (see ownCloud admin page) Latest version (just downloaded/installed in a development EC2 instance.)

Updated from an older ownCloud or fresh install: Fresh install

Where did you install ownCloud from: I’ve tried from the tar, from packages… all with the same result.

Signing status (ownCloud 9.0 and above): Unfortunately, I’m not sure what this is…

I have to restore the snapshot and do some configurations over again before I can post anything further as the system is currently down after my last attempt to enable encryption. I was hoping someone may have attempted or successfully done this already and have some guidance.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.