Error accessing Marketplace

marketplace

#1

Any ideas what might be causing this error?

No marketplace connection: cURL error 35: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

Running ownCloud on FreeNAS 9.10 and I recently manually updated from 10.0.2 to 10.0.4 and everything seemed to be working fine. No problems with clients connecting and I could log in to the Web UI. The Apps I tested worked fine and appeared to have updated correctly. When I went to have a look in the Marketplace tonight the error message pops up in a grey box with red text in the bottom right-hand corner, and nothing loads up. It says there is 1 update, but whatever I try and do just brings back the error.

I connect to ownCloud using SSL via a reverse proxy but nothing has changed there since updating to 10.0.4.

I did find a similar thread which suggested moving the /files_external/rootcerts.crt file and getting it to recreate but that hasn't fixed it.

Thanks


#2

Same here.
I also get the error when trying to download files from the marketplace from cli (using wget):

OpenSSL: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure
Unable to establish SSL connection.

Used to work before...


#3

I have the same issue here. I upgraded from OC9.1 to OC10.0.4 and cannot get access to the marketplace. I get the error in a red box:
"No marketplace connection: cURL error 35: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure"

And also get an update notification but nothing happens when I click on that. Otherwise I users can log in, but I have no apps


#4

Hello,

I have the same problem in both 10.0.3 and now 10.0.6. I am using owncloud from a bsdjail on a freeNAS server.

Contrary to @juandresen I get update notifications.

My owncloud installtion is accessed via a reverse proxy, but has outgoing connectivity.

Thanks


#5

An update: I think I have a similar setup as the OP @crazy_badger. I have a jail set up originally on FreeNAS 9 and now have updated to freeNAS 11.

Unfortunately, freeNAS does not allow to update the base system of a jail. You are stuck with it. That is, the version of openssl used is the one from freeNAS 9. Consequently curl uses the libssl.so from the old installation too.

The probably easiest way around this is to set up a new jail based on the freeNAS 11 and migrate the owncloud installation. Could be reasonably fast (create a new jail, point the data to the same directory, backup mysql and migrate the db). But then this jail will be frozen in time too.

On the other hand, freeNAS now seems to be deprecating jails in favour of docker containers. So the best thing might be to migrate to a docker, which perhaps is easier to maintain.

Another way might be to compile curl from source, making sure the libssl from the /usr/local is used.

I have not made my mind up yet. I'll probably try recompiling curl and then move on to a docker container.


#6

I have the same problem
do you manage to fix it ?


#7

My fix was maybe a little extreme!

I’m pretty sure the problem was the age of my FreeNAS jail, which was created back in 9.3 and therefore the version of FreeBSD it was running was EOL some time ago. I’d been unable to update any of the main packages for some time, but ownCloud could be updated manually until it needed a later version of SSL.

I’ve recently updated my FreeNAS box to 11.1 and with that comes a change to the jail management, with Warden now depreciated and iocage the preferred method for creating jails, with the added benefit that iocage jails can update the version of FreeBSD they were built with. I’ve recreated all the FreeNAS jails I used Warden for using iocage.

As part of this process, I decided to rebuild my ownCloud jail with Nextcloud instead! I’d been playing around with Nextcloud in a Docker container and felt it has moved on more than ownCloud had in the same period of time, so jumped ship. It updated using the WUI from 13.0.2 to 13.0.4 without any problems, something I’d never got ownCloud to do, and has a better selection of 3rd party apps than ownCloud did at 10.0.2.

Good luck finding your solution…