Error after upgrade "This ownCloud instance is currently in maintenance mode"

9.1.x
help

#1

I got up this morning and checked the old computer I have set up for my server. It wanted to run upates so I let it run updates. Before it did my regular workstation synced with my owncloud server with no problems. After the updates I noticed the owncloud icon in my task tray was grayed out, when I went to the site it gave me an error message

"This ownCloud instance is currently in maintenance mode, which may take a while.
This page will refresh itself when the ownCloud instance is available again.
Contact your system administrator if this message persists or appeared unexpectedly.
Thank you for your patience."

I did some digging for several hours, I restarted the server, restarted the web service. the version shows it's supposed to be 9.1.0.5 and other pages I've found with this error don't match up on what I'm seeing since my occ php doesn't seem to do anything or have any information in it.

Keep in mind I'm not the best Linux user so if there's a solution you're going to have to spell it out for me.

Operating system: Ubuntu 14.04


#2

Hi,

the official documentation has upgrading instructions:

https://doc.owncloud.org/server/9.1/admin_manual/maintenance/package_upgrade.html

where it is described that you need to manually put oC out of the maintenance mode.


#3

Did that, I got back an error:

Could not open input file: occ


#4

You need to switch to your ownCloud installation directory where the occ file exists before you can execute it.


#5

Okay, not to sound like an idiot, but how do I do that?


#6

http://www.comptechdoc.org/os/linux/usersguide/linux_ugbasics.html

might help here. The command you need is "cd"


#7

Okay, I navigated to the directory. It took me a moment to realize what you actually meant. I thought there was a new directory created and didn't know where it was until it dawned on me I was running this from the home folder. So I ran the command and maintenance mode was disabled. I still got no reaction on my web pages or my apps saying the client has to be upgraded or put into maintenance mode for the upgrade. I put it back into maintenance mode and try to update it, it says I have the latest version. I think there's a file that wasn't updated with the correct version number. I had found a similar post on this before but I can't find the file to check.


#8

This is very frustrating, any one has a solution? I am stuck on the same page (see message below);
only thing I did is change the maintenance mode to “false” (in the config.php), but then it bounces me back to upgrade software, which I confirm, then I am getting the message again
I was thinking to redo oC on another folder, but I rather avoid that, and fix this first.
Any thoughts?


This ownCloud instance is currently in maintenance mode, which may take a while.
This page will refresh itself when the ownCloud instance is available again.
Contact your system administrator if this message persists or appeared unexpectedly.
Thank you for your patience.