[error] Deleted 10.8.0.zip due to wrong checksum

Steps to reproduce

  1. Use web updater of an older OC 10.7.0.4 installation to upgrade to 10.8.0 fails.

Expected behaviour

Upgrade from 10.7.0.4 to 10.8.0 works

Actual behaviour

The web updater fails with error message
[error] Deleted 10.8.0.zip due to wrong checksum

Server configuration

Operating system:
FreeBSD13
Web server:
Apache
Database:
MySQL 5.7.37

PHP version:
7.4.3

ownCloud version: (see ownCloud admin page)
10.7.0.4

Updated from an older ownCloud or fresh install:
Updated many times from older OC versions, I think started at 7.x

Where did you install ownCloud from:
don’t remember, this installation is so old :wink:

Signing status (ownCloud 9.0 and above):
?

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

No errors have been found.

When I check the owncloud_data/updater-data/download folder, it is empty. When I try to download https://download.owncloud.com/server/stable/owncloud-complete-20210721.zip, rename it to 10.8.0.zip and upload it into the /download folder, the updater process still fails.

I appreciate any advice how I can best safely upgrade my old 10.7.0.4 installation to 10.8.0, and then to 10.9.0 and 10.10.0 afterwards.

Thanks in advance!

I think this is surely not an official upgrade method. Did you ever succeed with that?
And I think, you can upgrade directly 10.7.0.4 → 10.10.0.

If you are on ownCloud 8.2.11, 9.0.9, 9.1.X, or 10.X.Y you can go directly to the latest server version.

Be careful, the web-updater is a risky thing! IMHO a high certainty to fail.

Thanks for the warning @alfredb.
So it seems the webupdater of 10.7.0.4 is broken anyway, as it doesnt even recognize that there is a version 10.10 already.
What is the best way then to go from 10.7 to 10.10 directly? Manual upgrade like documented here?

Yes, that’s the one and only way to do it, IMHO.

10.10 successfully live for me, thanks again for the pointer in the right direction. will avoid web-updater from now on.

1 Like