Error GOAWAY for some folder when synching on a new PC


I recently added owncloud on a fresh install on my PC.
Since I did that, I have some error to sync at least one of the folder.

It work fine on some old install.

I have a message for a number of folder like that :
Server replied with an error while reading directory ‘path/another_path’ : GOAWAY received, cannot start a request

Can you help me ?

Thanks in advance


maybe you could use the issue template which i’m getting presented when creating a new thread in this “Server” category?

I think others are probably better able to help you if you provide more information about your environment (e.g. operating system, database, database version, specific database configuration). Those are all questions asked in that template which i think are asked for a good reason.

At the moment nearly everything is missing, even the ownCloud version you are using (e.g. an outdated ownCloud version could cause this problem). :frowning_face:

1 Like


Sorry, at first I selected desktop client as category, so I think the template did not show up for me when I changed the category.

Also, I tried to download my calibre folder from the web to put back in my local folder. It worked fine, but I still have some error in the client.

Here are my answer to the template :

Steps to reproduce

  1. I don’t really know, it appened when I installed the client on a newly installed PC.
    I created another account for my wife on this PC, and she have the same problem on her calibre folder.

Expected behaviour

The folder should be synchronized without error by the client.

Actual behaviour

I have an error for a number of sub folder of my calibre library folder that show an error in the client and the syncho doesn’t work.

Server configuration

Operating system:
Linux infongq-eu57 4.4.0-ui19255.033-uiabi1-infong-amd64 #1 SMP Debian 4.4.192-1~ui80+1 (2019-09-12) x86_64 GNU/Linux
Web server:
Ionos Hosting, I don’t know the exact version
MySql 5.5
PHP version:
PHP 7.3
ownCloud version: (see ownCloud admin page)
Updated from an older ownCloud or fresh install:
Manually updated from 10.3.1 after I found that problem to see if it’s better. I don’t remember the previous version
Where did you install ownCloud from:
tar from the owncloud site
Signing status (ownCloud 9.0 and above):
No errors have been found.

The content of config/config.php:

 php7.3-cli occ config:list system
The process control (PCNTL) extensions are required in case you want to interrup                                                                             t long running commands - see
    "system": {
        "instanceid": "ocfb8jpls452",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
        "datadirectory": "\/homepages\/17\/d147813795\/htdocs\/Owncloud-data",
        "overwrite.cli.url": "https:\/\/",
        "dbtype": "mysql",
        "version": "",
        "dbname": "db647630490",
        "dbhost": "",
        "dbtableprefix": "oc_",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "logtimezone": "UTC",
        "installed": true,
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpmode": "php",
        "mail_domain": "***REMOVED SENSITIVE VALUE***",
        "loglevel": 1,
        "theme": "",
        "maintenance": false,
        "trashbin_retention_obligation": "auto, 30",
        "versions_retention_obligation": "auto, 30",
        "enable_previews": false,
        "forcessl": true,
        "updater.secret": "***REMOVED SENSITIVE VALUE***"

List of activated apps:

 php7.3-cli occ app:list
The process control (PCNTL) extensions are required in case you want to interrupt long running commands - see
  - comments: 0.3.0
  - configreport: 0.2.0
  - dav: 0.5.0
  - federatedfilesharing: 0.5.0
  - files: 1.5.2
  - files_external: 0.7.1
  - files_mediaviewer: 1.0.1
  - files_sharing: 0.12.0
  - files_trashbin: 0.9.1
  - files_versions: 1.3.0
  - firstrunwizard: 1.2.0
  - market: 0.5.0
  - notifications: 0.5.0
  - provisioning_api: 0.5.0
  - systemtags: 0.3.0
  - templateeditor: 0.4.0
  - twofactor_totp: 0.6.1
  - updatenotification: 0.2.1
  - encryption
  - external
  - federation
  - user_external

Are you using external storage, if yes which one: local/smb/sftp/…
Are you using encryption: yes/no
Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

Client configuration

Operating system:
Windows 10 pro


Web server error log

I selected some log with grep, but nothing appears for the folder “Calibre_Fabien/Colfer,%20Eoin/Le dernier gardien” witch come as the first one with an error in the client

 cat logs/access.log.current |grep "Calibre_Fabien/Colfer,%20Eoin/" - - [03/Jan/2020:20:20:44 +0100] "PROPFIND /remote.php/dav/files/Althor/Calibre_Fabien/Colfer,%20Eoin/Code%20Eternite%20(1207) HTTP/1.1" 207 3180 "-" "Mozilla/5.0 (Windows) mirall/2.6.0 (build 12644)" "-" - - [03/Jan/2020:20:20:44 +0100] "PROPFIND /remote.php/dav/files/Althor/Calibre_Fabien/Colfer,%20Eoin/Colonie%20perdue%20(1635) HTTP/1.1" 207 3185 "-" "Mozilla/5.0 (Windows) mirall/2.6.0 (build 12644)" "-" - - [03/Jan/2020:20:20:44 +0100] "PROPFIND /remote.php/dav/files/Althor/Calibre_Fabien/Colfer,%20Eoin/Encore%20une%20chose__%20(803) HTTP/1.1" 207 3210 "-" "Mozilla/5.0 (Windows) mirall/2.6.0 (build 12644)" "-" - - [03/Jan/2020:20:20:45 +0100] "PROPFIND /remote.php/dav/files/Althor/Calibre_Fabien/Colfer,%20Eoin/L'assassin%20malgre%20lui%20(1970) HTTP/1.1" 207 3240 "-" "Mozilla/5.0 (Windows) mirall/2.6.0 (build 12644)" "-" - - [03/Jan/2020:20:20:45 +0100] "PROPFIND /remote.php/dav/files/Althor/Calibre_Fabien/Colfer,%20Eoin/Le%20complexe%20d'Atlantis%20(1637) HTTP/1.1" 207 3244 "-" "Mozilla/5.0 (Windows) mirall/2.6.0 (build 12644)" "-" - - [03/Jan/2020:20:20:45 +0100] "PROPFIND /remote.php/dav/files/Althor/Calibre_Fabien/Colfer,%20Eoin/Artemis%20Fowl%20(1228) HTTP/1.1" 207 3174 "-" "Mozilla/5.0 (Windows) mirall/2.6.0 (build 12644)" "-" - - [03/Jan/2020:20:20:45 +0100] "PROPFIND /remote.php/dav/files/Althor/Calibre_Fabien/Colfer,%20Eoin/Le%20paradoxe%20du%20temps%20(1636) HTTP/1.1" 207 3234 "-" "Mozilla/5.0 (Windows) mirall/2.6.0 (build 12644)" "-" - - [03/Jan/2020:20:20:45 +0100] "PROPFIND /remote.php/dav/files/Althor/Calibre_Fabien/Colfer,%20Eoin/Mission%20polaire%20(1227) HTTP/1.1" 207 3190 "-" "Mozilla/5.0 (Windows) mirall/2.6.0 (build 12644)" "-" - - [03/Jan/2020:20:20:45 +0100] "PROPFIND /remote.php/dav/files/Althor/Calibre_Fabien/Colfer,%20Eoin/Operation%20Opale%20(1672) HTTP/1.1" 207 3189 "-" "Mozilla/5.0 (Windows) mirall/2.6.0 (build 12644)" "-"

ownCloud log (data/owncloud.log)

Empty file ?

Browser log

It’s not with the browser but only with the client that I have this problem.

Thanks again for your help and sorry for the missing template answer.

Best regards


If someone find this and is interested, I found this thread as I was searching for a solution.

So it seems that it’s a client issue and not a server one.
I tried with the 2.5.4 client, and it’s fine now.

I will try anew when 2.6.1 wich should disable http/2 come out.

Best regards

1 Like