Error: HTTP/2 protocol error when using Windows client installed from ownCloud-2.5.1.10973.10850.msi


#1

Expected behaviour

I expected the desktop client to work.

Actual behaviour

Error: HTTP/2 protocol error

Steps to reproduce

  1. Installed OwnCloud using default settings on server
  2. Installed latest client for Windows: ownCloud-2.5.1.10973.10850.msi
  3. Error: HTTP/2 protocol error

Server configuration

Operating system: Looks like it is RedHat Linux. cat /proc/version reports:
Linux version 2.6.32-896.16.1.lve1.4.54.el6.x86_64 (mockbuild@buildfarm03.cloudlinux.com) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-18) (GCC) ) #1 SMP Wed May 2 07:43:19 EDT 2018

Web server: Apache (But I can’t seem to get the version from httpd -v)
PhyMyAdmin reports: cpsrvd 11.76.0.14

Database: MySql 5.1.73

PHP version: 7.2.7

ownCloud version: ownCloud 10.0.10 (stable)

Storage backend (external storage):

Client configuration

Client version:

Operating system: Windows 10 x64

OS language: English

Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only):

Installation path of client: C:\Users<username with no spaces>\ownCloud

Workaround

  1. Uninstall the ownCloud-2.5.1.10973.10850 client
  2. Install the prior client from ownCloud-2.5.0.10359-setup.exe
  3. Client now logs in just fine.

Hope this helps.
-James

PS - You cannot create optional tags in this interface.


#2

Sounds similar to HTTP/2 protocol error since ownCloud client update

Please also check the linked issue on GitHub.com:
https://github.com/owncloud/client/issues/6843


#3

Agreed, but that issue is marked as closed. This does not inspire confidence that a fix is coming.


#4

Hey,

if i understand the linked issue correctly no fix is required from ownCloud client side. According to a comment the malfunctioning web server needs to be fixed to correctly answer to the HEAD requests via http/2.


#5

I tried the cURL test and did not have the problem it exposed. Also, my server is not “misconfigured”. I think there is a bug here.


#6

Hey,

if you think there is a bug here then i think its probably better to report this again to the bug tracker in a new issue. When doing so you could refer to the old issue and mention that the test from there doesn’t fail on your server and that you think there might be a bug in the client.