Error in owncloud when restoring directory data

update
9.1.x
help

#1

Steps to reproduce
1. I installed a clean Ubuntu 16.04, apache2, mariadb,
PHP 7.0 (libapache2-mod-php7.0 php7.0-common php7.0-mysql php7.0-intl php7.0-mcrypt php7.0-mbstring php7.0-imap php7.0-cli php7.0-gd php7.0-json php7.0-curl php7.0-xml php7.0-zip)
2. Created owncloud database dump and restored
sudo mysql -u root -pdb_pass owncloud </tmp/db_owncloud.20161111.020501.sql
3. Copy the old configuration file

Expected behaviour
Errors should not be

Actual behaviour
I go to the interface in owncloud -> admin page and get the error: "This server has no working Internet connection This means that some of the features like mounting external storage, notifications about updates or installation of third-party apps will not work Accessing.. files remotely and sending of notification emails might not work, either. We suggest to enable Internet connection for this server if you want to have all features. "

If not restore the database, then there is no error. How do you recommend to restore the database to not receive this error?

Server configuration
Operating system: Ubuntu 16.04
Web server: Apache 2.4.18
Database: MariaDB 10.0
PHP version: 7.0
ownCloud version (see ownCloud admin page): 9.1.2.5
Updated from an older ownCloud or fresh install: 9.1.1.3
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): No

ownCloud log (data / owncloud.log)

{ "ReqId": "8OxajvTnj6aFzOYUr2du", "remoteAddr": "192.168.100.11", "app": "core", "message": "Could not get application: cURL error 77: error setting certificate verify locations: \ n CAfile : \ / mnt \ / hdd01 \ / ofiles \ / files_external \ /rootcerts.crt \ n cApath: \ / etc \ / ssl \ / certs "," level ": 3," time ":" 2016-11-24T12: 39: 01 + 03: 00 "," method ":" GET "," url ":"? \ / index.php \ / settings \ / apps \ / list category = enabled & includeUpdateInfo = 1 "," user ":" admin "}
{ "ReqId": "8OxajvTnj6aFzOYUr2du", "remoteAddr": "192.168.100.11", "app": "core", "message": "Could not get application: cURL error 77: error setting certificate verify locations: \ n CAfile : \ / mnt \ / hdd01 \ / ofiles \ / files_external \ /rootcerts.crt \ n cApath: \ / etc \ / ssl \ / certs "," level ": 3," time ":" 2016-11-24T12: 39: 01 + 03: 00 "," method ":" GET "," url ":"? \ / index.php \ / settings \ / apps \ / list category = enabled & includeUpdateInfo = 1 "," user ":" admin "}
{ "ReqId": "8OxajvTnj6aFzOYUr2du", "remoteAddr": "192.168.100.11", "app": "core", "message": "Could not get application: cURL error 77: error setting certificate verify locations: \ n CAfile : \ / mnt \ / hdd01 \ / ofiles \ / files_external \ /rootcerts.crt \ n cApath: \ / etc \ / ssl \ / certs "," level ": 3," time ":" 2016-11-24T12: 39: 01 + 03: 00 "," method ":" GET "," url ":"? \ / index.php \ / settings \ / apps \ / list category = enabled & includeUpdateInfo = 1 "," user ":" admin "}

Integrity status for oC9 +

No errors have been found.

#2

I am not a specialist, but it seems that the error message you received deals with a problem of certificate. Did you change the directory where the certificate are located in the old version?
If so, you should place the certificate at the same location in the new configuration.


#3

Thank you very much for your help. I downloaded the newest certificate for the site (https://curl.haxx.se/docs/caextract.html) and put it in my directory data (/mnt/hdd01/ofiles/files_external).
Now the admin panel I have no errors! I am happy to :grinning: