ERROR: Unable to handle this request. HTTP ERROR 500

help

#1

Hello everyone.

First of all please let me say that i've searched web intensively to find the solution but all i came up with DreamHost zend_extension=opcache.so line. I dont have that line since i run PHP 5.4.16.
Owncloud version 8.1.9
BUT here is the interesting thing: when i do version check from /var/www/html/owncloud
i get Cloud version 8.1.9

when i do version check from /usr/share/owncloud
Iget following,
ownCloud is not installed - only a limited number of commands are available
ownCloud version 9.0.2

Im very close to total noob in centos\owncloud please advice how can i solve error 500

Thank you in advance.


#2

Hi,

you probably have mixed two different installation ways in the past. Please clean-up both installations and do a fresh installation.


#3

I did not install system myself. All i was doing past year running updates and that is it, Everything worked up till last Friday.


#4

You probably installed a package from the centOS-community (/usr/share/owncloud) and on top of that a version either from the owncloud packages or manual install.

What did you do last Friday? Running updates? Did the OC 9.0.2-setup break or what is your actual problem except for two setups?


#5

I did usual whole system update (centos etc) with yum update. The actual problem is that when i try to access cloud over http it gives me error

The cloud.myweb.com page isn’t working

cloud.myweb.com is currently unable to handle this request.
HTTP ERROR 500


#6

You you check, which of the installations is the one you used. You can see the folder of the user at: /var/www/html/owncloud/data/username/files.
And perhaps which package was installed by yum (first which source: https://serverfault.com/questions/62026/how-to-know-from-which-yum-repository-a-package-has-been-installed)


#7
  1. I followed provided path and there is not user. The only file i have in data is owncloud.log
  2. and here is source info

Name : owncloud
Version : 9.0.2
Release : 4.el7
Architecture: noarch
Size : 55648909
Packager : Fedora Project
Group : Unspecified
URL : http://owncloud.org
Repository : epel
Summary : Private file sync and share server
Source : owncloud-9.0.2-4.el7.src.rpm

so i guess the 9.0.2 did land on top of the 8? but only portialy?


#8

That is possible. So all your data are in /var/www/html/owncloud/data/*? Or in /usr/share/owncloud/data/*?

Before you change anything, please make a backup of your database (you can do it with web-interfaces like phpmyadmin or directly on the terminal with mysqldump), the config/ and the data/ folder of the setup which actually contains the data.

If the centOS package is the one your are NOT using (and if that is /usr/share/owncloud and /usr/share/owncloud/data/* doesn't contain your data), if've you've made your backup and double checked, you can try and remove the centOS package.
If it is not the centOS package you want to remove, we have to figure out, how you installed the other version.


#9

/var/www/html/owncloud/data/ - has data dir but there is only owncloud.log file in it.
/usr/share/owncloud/data/ - doesnt even have data folder.

Not sure i understood you correctly. Are you talking about backing up configuration data or the actual data that i an accesing via HTTP?

HTTP data is back up. I have latest files backed on outside source + there is a redundancy on top of redundancy so this is only matter of making cloud work and reconnecting data back. That is why i am thinking about just wiping everything and do fresh 9 installation


#10

So where are your data, do you have a third setup somehwere?
try to use find or locate to find other possible locations of owncloud.


#11

find comes up with this

./etc/lvm/backup/data
./usr/share/php-patchwork-utf8/data
./usr/share/php/Patchwork/Utf8/data
./usr/share/php/Punic/data
./usr/share/icons/hicolor/192x192/stock/data
./usr/share/icons/hicolor/64x64/stock/data
./usr/share/icons/hicolor/48x48/stock/data
./usr/share/icons/hicolor/128x128/stock/data
./usr/share/icons/hicolor/256x256/stock/data
./usr/share/icons/hicolor/16x16/stock/data
./usr/share/icons/hicolor/scalable/stock/data
./usr/share/icons/hicolor/36x36/stock/data
./usr/share/icons/hicolor/72x72/stock/data
./usr/share/icons/hicolor/32x32/stock/data
./usr/share/icons/hicolor/24x24/stock/data
./usr/share/icons/hicolor/96x96/stock/data
./usr/share/icons/hicolor/22x22/stock/data
./var/www/html/owncloud/apps/user_ldap/tests/integration/data
./var/www/html/owncloud/apps/files_locking/tests/data
./var/www/html/owncloud/apps/files_antivirus/tests/data
./var/www/html/owncloud/3rdparty/punic/punic/code/data
./var/www/html/owncloud/3rdparty/patchwork/utf8/class/Patchwork/Utf8/data
./var/www/html/owncloud/data
./var/www/lighttpd/owncloud/apps/files_locking/tests/data
./var/www/lighttpd/owncloud/3rdparty/punic/punic/code/data
./var/www/lighttpd/owncloud/3rdparty/patchwork/utf8/class/Patchwork/Utf8/data
./var/www/lighttpd/owncloud/data
./var/lib/owncloud/data
./run/udev/data
./dev/data
./sys/kernel/debug/boot_params/data
./sys/kernel/boot_params/data


#12

Another one. Are there your data?


#13

Nope

cd ./var/www/lighttpd/owncloud/data
total 12K
drwxr-xr-x. 2 lighttpd lighttpd 4.0K Nov 5 2015 .
drwxr-xr-x. 13 lighttpd lighttpd 4.0K Jul 12 2015 ..
-rw-r-----. 1 lighttpd lighttpd 235 Jul 12 2015 owncloud.log

If you look at my first post the version 9 give out following message

ownCloud is not installed - only a limited number of commands are available
ownCloud version 9.0.2

Maybe thats the thing. There is no data?


#14

By the way if i open log file in /var/www/html/owncloud/data
i get this

1 {"app":"PHP","message":"fopen(\/var\/www\/html\/owncloud\/config\/config.php): failed to open stream: No such file or dir ectory at \/var\/www\/html\/owncloud\/lib\/private\/config.php#142","level":3,"time":"2015-02-10T15:39:03+00:00"}¬

What should be the contend of the data folder?


#15

Hi,

i really recommend to delete everything and start from scratch. As you can see you even have three different installation folders. How should some one guess which one the correct installation was?

Making a good backup on client side and installing a fresh oC 9.1 installation is probably the cleanest and fastest way.


#16

As i stated above, that what i am thinking but here are the questions i have:
1. I cant do client side backup (if i understand correctly client side is HTTP access) but i have backups i've done from centos. This backups are done in version 8, can i load them in version 9?
2. Do i need to back up configuration settings or just re-setup everything again?


#17

You can take a backup from server or all clients. But verify manually that the data are really present, put it on an external disk, disconnect the disc and then start reinstalling.

If you knew where you exactly installed it, you could do that. I terms of files, they should be in backups. What will be lost is everything in the database which would be most app-data (calendar, contacts, bookmarks, ...), user settings, user preferences, sharing, ...


#18

Also be aware that the three different installations might also have messed around with the webservers configs and you might face similar / other issues when just installing from scratch


#19
  1. All the data was always backed up into external SSD so yeah its defiantly there.
  2. Well, i wasn't the one who setup the server originally, i just ook over it, which makes everything that much harder, but on the other hand none of the users use calendar, contacts, bookmarks etc

#20

Should i just reinstall centOS as well then?

PS Heh its all sounds logical but a bit to blurred for me ...im 2 out of 10 in linux. I guess ill have to do lots of googling.
Thank you so much for your help guys.

PS2 sorry cant post anymore as new user,. Have to wait 18hours.