Error uploading file "%filename%": Error write on disk

help

#1

Hello!

Have a problem with upload big files ( > 500 mb) to the server OwnCloud (ver. 9.0) from web.
PHP 5.5.9-1ubuntu4.14 (cli) (built: Oct 28 2015 01:34:46)
OS Ubuntu 14.04.4 LTS
Any browser.

php.ini
output_buffering = 16384
max_execution_time = 3600
post_max_size = 16G
upload_tmp_dir = /var/www/owncloud/data/tmp
upload_max_filesize = 16G

.htaccess


php_value upload_max_filesize 16G
php_value post_max_size 16G
php_value memory_limit 5120M
php_value mbstring.func_overload 0
php_value always_populate_raw_post_data -1
php_value default_charset 'UTF-8'
php_value output_buffering 0

SetEnv htaccessWorking true



php_value upload_max_filesize 16G
php_value post_max_size 16G
php_value memory_limit 512M
php_value mbstring.func_overload 0
php_value default_charset 'UTF-8'
php_value output_buffering 0

SetEnv htaccessWorking true

.user.ini
upload_max_filesize=16G
post_max_size=16G
memory_limit=5120M
mbstring.func_overload=0
always_populate_raw_post_data=-1
default_charset='UTF-8'
output_buffering=0

/var/www/owncloud/config/config.php
'tempdirectory' => '/var/www/owncloud/data/tmp',

df -h
root@owncloud:/etc/php5/apache2# df -h
Filesystem Size Used Avail Use% Mounted on
udev 366M 12K 366M 1% /dev
tmpfs 75M 556K 74M 1% /run
/dev/sda1 40G 20G 18G 53% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
none 5.0M 0 5.0M 0% /run/lock
none 371M 0 371M 0% /run/shm
none 100M 0 100M 0% /run/user
none 371M 0 371M 0% /tmp

But problem not solved.
Please help!


Broken rights on tmp directory
#2

You either need to make more space on /tmp or use the php.ini config option upload_tmp_dir for the reasons explained here:


#3

I already have this string in php.ini, and permission on folder is correct (755).
php.ini
output_buffering = 16384
max_execution_time = 3600
post_max_size = 16G
upload_tmp_dir = /var/www/owncloud/data/tmp
upload_max_filesize = 16G


#4

I try

mount -o remount,size=5G /tmp

root@owncloud:/etc# df -h /tmp
Filesystem Size Used Avail Use% Mounted on
none 5.0G 0 5.0G 0% /tmp

but problem not solved


#5

Problem is SOLVED!

REASON: no permission www-data in new temp directory (((

chown -R www-data:www-data /var/www/owncloud/data/tmp