Error when trying to connect (cURL error 6: Could not resolve host: How to fix?

I use OwnCloud on Univention Corporate Server and tried to set up my OnlyOffice Server, but I get this error msg:

Error when trying to connect (cURL error 6: Could not resolve host:

I got the same error when I tried to upgrade the system. In this case I did it manually.

Does anyone know how I can do the OnlyOffice implantation manually or how I can solve it?

I saw an other nearly similar article on this forum but it didn’t help me. They said it is an DNS error. but I don’t know how or where to change my DNS settings.

Here are some details:
OS: UCS 4.4-2
OwnCloud v:
Other installed apps: OnlyOffice, lets-encrypt
curl v: 7.52.1 (I know it's not up to date, but it should work either and I don't know how to update it)

When I try manually to connect to the OnlyOffice Server it works.

PS: I come from Germany, sorry for my bad english.


it seems like a DNS problem to me too, actually your server can’t find a decent DNS server to resolve
I don’t know anything about Univention Corporate Server and I doubt it’s an ownCloud problem, I think you’d have more luck on a forum dedicated to that kind of server.
I’d like to better help but I doubt I can, I found that if it’s of any use.
Viel glück ! :slight_smile:


Hi @Nikl4s,
Hast du eine existierende Domain für deinen UCS benutzt? Sind DNS Einträge ordentlich gesetzt und können alle Einträge aufgelöst werden?
Übrigens kann man den Hostnamen, den du geschwärzt hast, in der gelben Fehlermeldung sehen.

@cs35 ownCloud ships an appliance based on the Univention Corporate Server.


Hello @Nikl4s,

has your UCS system been setup with the same fully qualified domain name (FQDN) that you are using to access ownCloud?

There are setups that use a different fqdn for external and internal access. There are already some postings at Univention Help. Maybe it helps to have a look at

Best regards,