Errors on freshly upgraded host (14.04 to 16.04)


#1

I’d been running the previous version of Owncloud (not sure what the version number was) on Ubuntu 14.04 which worked perfectly. I upgraded Ubuntu 14.04 to 16.04 via do_release_upgrade, and fixed the minor nits that caused. When I went to try to access
owncloud (hosted on this upgraded server) I got a bunch of errors, which I didn’t note… Since there was a newer version (10.0.10), I followed the upgrade path, and now when
I try to login via the web interface, I get (on what would be the owncloud web login screen)
the following

PHP module intl not installed.
Please ask your server administrator to install the module.

AND

PHP modules have been installed, but they are still listed as missing?
Please ask your server administrator to restart the web server.

The first time I got this, I installed php_intl, which was missing and I restarted
Apache2…

I have done this countless times and still get the same messages… What AM I
missing???


#2

Hey,

i think there are two possibilities that either php-intl wasn’t installed for the PHP version you’re currently running or an installation of php-intl isn’t enough and you need to enable it afterwards.


#3

Not quite sure how one would enable it… To my understanding when you install a php addin from “apt-get install php-intl” it is by definition installed. I’m using php 5.6.39 and I checked
that both “php-intl” and “php5-intl” are installed.

Thanks
Dave


#4

Guess I’m actually replying to myself… Seems this server has both php 5.6 AND php 7.0 on it… For some damn reason, even after I purged the php7-common and then tried installing
php-intl, apt insists upon reinstalling php7.0-common, php-intl and php7.0-intl… and I don’t
get the php_intl.so in the php extensions directory. I’m pulling my damn hair out… What AM I missing???


#5

Hey,

it seems this is not necessarily the case and you can enable/disable PHP (as well as Apache) modules separately:


#6

Let me reinterate here… Apparently when I upgraded this vps from 14.04 to 16.04, it stuffed php7.0 on also. I have installed the php-intl plugin many times, and I get the php-intl, that I would expect to be for php5.X, but also get php7-intl. Even after I purged php7-common from the system, if I do an apt-get install php-intl, it insists on putting php-intl, php7-intl AND stuffs php7-common BACK on the system. Even with the php-intl alledgedly installed, there is no phpintl.so in the php plugins directory… WTF is going on??? pulling my hair out by the roots…


#7

Hey,

i think this behavior is expected. Ubuntu 14.04 had PHP 5.x where 16.04 has PHP 7.0. So if you’re running Ubuntu 16.04 then i think you need to uninstall all PHP5.x packages and only keep the PHP 7.0 ones.

The problem is probably solving itself as soon as PHP 5.x is uninstalled and your web server is starting to use the PHP 7.0 (and thus the php7-intl) packages.

In doubt you could also consult an Ubuntu forums like https://ubuntuforums.org/ as this seems to me like some kind of configuration / environmental issue.


#8

I’ve done a purge of php5x, and installed php7.0 but the php7-intl and php7-mysql addins install via apt but don’t appear in the Apache2 mods-available… I’ll try over on the Ubuntu forum… Thanks


#9

Hey,

php7-intl and php7-mysql are PHP modules/extensions and i don’t think that those will show up in the Apache2 mods-available. They probably should show up somewhere in /etc/php/7.0 instead.