ESX Appliance install gives me Univention server but not the owncloud branded version

appliance

#1

Hi everybody,

I have tried installing the ESX appliance image from https:// owncloud.org /download/.

On the console of the virtual machine I see an own-cloud branded Univention server. Following the successful configuration of the server the console now displays an “ownCloud Appliance” screen that tels me to log on to https:// ipaddress and ope the web management interface.

When I browse to https:// ipaddress I am forwarded to https:// ipaddress/ univention/ portal and I see a Univention server logon, not an ownCloud branded management interface.

Initially there was an overlay that I had to close that said I should log on with owncloud / owncloud and there was information within the help system. I closed this and that was the last mention I found of ownCloud!

I cannot log into the web console using owncloud / owncloud as I should be able to.

I can however log in with Administrator and the password I selected during configuration. Once I’ve done this I have an Univention-branded server. OwnCloud isn’t listed as an installated app. If I try and install it the docker deployment fails - presumably as it’s already installed.

I tried installing it a second time and got exactly the same result.

What am I missing here?!

Many thanks for any help received! :slight_smile:

Steps to reproduce

  1. Download .OVF appliance file (https://appcenter.software-univention.de/univention-apps/current/owncloud/Univention-App-owncloud-ESX.ova) v10.0.7
  2. Deploy appliance
  3. Configure appliance
  4. Try to log on to HTTPS console of appliance

Expected behaviour

At HTTPS logon I should see an ownCloud branded Univention server and should be able to log on with owncloud/owncloud

Actual behaviour

At HTTPS logon I see an unbranded Univention server and cannot log on with owncloud/owncloud. I can log on with Administrator but I log on to an unbranded Univention server.

Server configuration

ESXI 5.1.0


#2

Please wait a little bit, a new version will be released shortly fixing a bug that caused the situation you are in now. I think 1-2 Days.


#3

Many thanks. I will keep my eyes peeled! :slight_smile:


#4

Anyone know if this is still an issue? Just downloaded the latest release from the website, and the Univention appliance doesn’t appear to have ownCloud installed. Can’t manually install the app either - errors out.


#5

Can you post me the link you got the appliance from?


#6

#7

How do you want to setup the appliance?


#8

This is my first go at ownCloud, so I’m not entirely sure. When I spun it up yesterday, I tried to join it to Active Directory. I assume that’s what you mean? The AD logon was working because I could login to UIC with my domain admin account. ownCloud, however, was inaccessible and (as far as I could tell) not installed.

Not sure if an AD-joined appliance will best fit our needs. Standalone accounts may work better for our current use case. I’ll need to test all of this out.


#9

Yeah, the AD Join sounds important but if you want your AD users to be able to log in to ownCloud with their AD credentials - there is an easier way to do this.

The AD Join feature of the appliance is a complicated one, and should only be used by people with a lot of experience in univention and AD.

I would suggest you install the appliance again, this time without the AD join.


#10

Update: I think I have this figured out. Thanks, dmitry, for all the guidance!

Alright, so it appears ownCloud is active now that I deployed without AD Join. How do I control user login via AD credentials as you mentioned? Also, I’m looking to cloud-enable shares on my Windows file server. Would the ACLs set there still apply within ownCloud?


#11
  • How do I control user login via AD credentials as you mentioned?

https://doc.owncloud.com/server/10.0/admin_manual/configuration/user/user_auth_ldap.html?highlight=ldap

Quick summery - go to ownCloud, Settings, “User Authentication with LDAP”, Add an LDAP Server.

Add your AD as a second server, and your users will be able to authenticate with their AD credentials.

  • Would the ACLs set there still apply within ownCloud?

If they have a home drive / home folder, you can mount the share as a SMB Share in the Storage section of the Settings. If the user has the right credentials + permissions = he / she can access the share.

https://doc.owncloud.com/server/10.0/admin_manual/configuration/files/external_storage/smb.html?highlight=smb