Excluded_directories in config don't work

I excluded 2 folders from scan of owc, but the result scan give me always warning:

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

I wrote into config.php:

‘excluded_directories’ => [
‘services’,
‘cronjobs’,
]

that files are into owncloud folder.
thanks

the intere file config is:

<?php $CONFIG = array ( 'instanceid' => 'xx', 'passwordsalt' => 'xx', 'secret' => '+MawUtM9f2aruJV/OQ+xx+/36gRN/', 'trusted_domains' => array ( 0 => 'xxx', ), 'datadirectory' => 'xxx', 'overwrite.cli.url' => 'xxx', 'dbtype' => 'mysql', 'version' => '10.2.1.4', 'dbname' => 'owncloud', 'dbhost' => 'localhost', 'dbtableprefix' => 'oc_', 'dbuser' => 'oc_administrato2', 'dbpassword' => 'xxx', 'logtimezone' => 'UTC', 'installed' => true, 'loglevel' => 2, 'maintenance' => false, 'filelocking.enabled' => true, 'memcache.locking' => '\\OC\\Memcache\\Redis', 'memcache.local' => '\\OC\\Memcache\\Redis', 'redis' => array ( 'host' => 'localhost', 'port' => 6379, 'timeout' => 0.0, 'password' => '', ), 'log_rotate_size' => 209715200, 'integrity.ignore.missing.app.signature' => array ( 0 => 'my-theme', ), 'integrity.excluded.files' => array ( 0 => '.DS_Store', 1 => 'Thumbs.db', 2 => '.directory', 3 => 'core/img/background.jpg', ), 'excluded_directories' => [ 'services', 'cronjobs', ] );

Hey,

i think this is not a topic matching the purpose of the “Development” category but more like something which should be discussed in the “Server” category:

Any discussion around anything related to the development around any of the ownCloud components.
This could be discussions about features, technical requirements like supported PHP versions, new design ideas and so on.

Please do not use this category for support or help requests

About the Development category

Maybe you can edit your post and set a better fitting category?

Concerning your question: I don’t think that you can use excluded_directories to exclude directories from the integrity check. At least the documentation below doesn’t include any references on the integrity check:

https://doc.owncloud.com/server/10.2/admin_manual/configuration/server/excluded_blacklisted_files.html

Maybe the integrity.excluded.files configuration options is what you are looking for?

https://doc.owncloud.com/server/10.2/admin_manual/configuration/server/config_sample_php_parameters.html#exclude-files-from-the-integrity-checker-command

This post was flagged by the community and is temporarily hidden.

So don’t exist in owc the possibility of exclude whole folder… it seems strange.
I have a my folder into owncloud folder and it never pass the integrity check, do I have to take that message forever?
it seems strange…

Hey,

have you tried to add both folders to the correct integrity.excluded.files configuration option and re-scanned the integrity afterwards? Maybe this configuration option also accepts folders / directories?

I done:

‘integrity.excluded.files’ =>
array (
0 => ‘.DS_Store’,
1 => ‘Thumbs.db’,
2 => ‘.directory’,
3 => ‘core/img/background.jpg’,
4 => ‘services’,
5 => ‘cronjobs’,
),

where the lasts rows are name folders (from owc root), but it doesn’t work… How do I resolve?
thanks

Hey,

if you have already re-scanned the integrity after adding the directories then i think it could be possible that this config option only accept files and not directories?