Expires module apache2

hosting

#1

Steps to reproduce

  1. edit .htaccess:
    add the following lines below the line saying "#### DO NOT CHANGE ANYTHING ABOVE THIS LINE ####":
    IfModule mod_expires.c
    ExpiresActive On
    ExpiresByFile /var/www/owncloud/core/img/* "access 1 year"
    ExpiresDefault "access 1 month"
    /IfModule

left out the <> signs in order to show the actual complete text.

  1. type in terminal:
    a2enmod expires
  2. type in terminal:
    service apache2 restart
  3. reload owncloud page
  4. error page is shown on the screen

Expected behaviour

Tell us what should happen
the page should load normally and save biggest website files on the computer reaching out to the website.

Actual behaviour

Tell us what happens instead
the server drops into the error page

Server configuration

Operating system:
Linux ubuntu3 4.4.0-92-generic #115-Ubuntu SMP Thu Aug 10 09:04:33 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Web server:
apache2, Server version: Apache/2.4.18 (Ubuntu)

Database:
sqlite
PHP version:
php 7.0
ownCloud version: (see ownCloud admin page)
ownCloud 9.1.6 (stable)

Updated from an older ownCloud or fresh install:
fresh install
Where did you install ownCloud from:
repo
Signing status (ownCloud 9.0 and above):
stable

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results into https://gist.github.com/ and puth the link here.

actual results:
no errors were found

The content of config/config.php:

<?php
$CONFIG = array (
'updatechecker' => false,
'instanceid' => 'oc5023ofiln4',
'passwordsalt' => 'ir/mFKqr9TC/oFvFxwn69I/RKFeIlO',
'secret' => 'GPgVw26f2vsdbxw3Pimvb0thMkJMN61zPoTlaGYCt7G7gqQZ',
'trusted_domains' =>
array (
0 => '192.168.178.55',
1 => '*',
),
'datadirectory' => '/var/www/owncloud/data',
'overwrite.cli.url' => 'http://192.168.178.55',
'dbtype' => 'sqlite3',
'version' => '9.1.6.2',
'logtimezone' => 'UTC',
'installed' => true,
'memcache.local' => '\\OC\\Memcache\\APCu',
'mail_smtpname' => '*',
'mail_from_address' => '*',
'mail_smtppassword' => '*',
'mail_smtpmode' => 'smtp',
'mail_smtpauth' => true,
'mail_smtpauthtype' => 'LOGIN',
'mail_smtphost' => '*',
'mail_smtpport' => '*',
'mail_domain' => '*',
'mail_smtpsecure' => '*',
'enable_previews' => true,
);


#2

Can we see a screenshot? Or some error messages from the logs?


#3

in the owncloud.log file there isn't said anything about this error.


#4

anything in the apache logs?


#5

nope nothing there either...


#6

are you sure the apache config is done right? just asking - I'm out of ideas.


#7

I just did a complete reïnstall, which took me a day to reconfigure, but it's working again. No idea what the problem could have been...