External storage does not work (dropbox + webdav)

external_storage
10

#1

Steps to reproduce

1Upgrade from owncloud 9 to 10. I already had dropbox external storage that I added on my server and a webdaw on my personal computer which is on debian.

Expected behaviour

The external storages should remain connected as it was under owncloud 9.

Actual behaviour

The external storages are not connected. I get this message for dropbox when I connect to owncloud with my browser:

Dropbox API rate limit exceeded. Do you want to review mount point config in admin settings page?

On my personal computer, the webdav sharing does not work anymore. I connected my owncloud account with gnome. It is how I was connected to my cloud with webdav. When I click on the tab of my cloud on my personal computer which is on debian 9, I get this message (I translated it from French to English):

Impossible to access to "user_name@cloud_dns"
This share does not support WebDav

Server configuration

Operating system:
Debian GNU/Linux 9.3 (stretch)
Web server:
Apache/2.4.25 (Debian)

Database:
Apache/2.4.25 (Debian)

PHP version:
PHP 7.0.19-1
ownCloud version: (see ownCloud admin page)
10.0.4.4
Updated from an older ownCloud or fresh install:
owncloud 9
Where did you install ownCloud from:
debian stretch backports
Signing status (ownCloud 9.0 and above):

No errors have been found

The content of config/config.php:

{
    "system": {
        "updatechecker": false,
        "instanceid": "octg8xzbc7wj",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
            "IP of the server",
            "cloud dns"
        ],
        "datadirectory": "\/var\/www\/owncloud\/data",
        "overwrite.cli.url": "http:\/\/cloud.debian-economist.eu",
        "dbtype": "mysql",
        "version": "10.0.4.4",
        "dbname": "owncloud",
        "dbhost": "localhost",
        "dbtableprefix": "oc_",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "logtimezone": "UTC",
        "installed": true,
        "ldapIgnoreNamingRules": false,
        "maintenance": false,
        "loglevel": 2,
        "debug": false
    }
}

List of activated apps:

Enabled:
  - activity: 2.3.6
  - audioplayer: 2.2.1
  - bookmarks: 0.10.2
  - calendar: 1.5.4
  - comments: 0.3.0
  - configreport: 0.1.1
  - contacts: 1.5.3
  - customgroups: 0.3.5
  - dav: 0.3.2
  - diagnostics: 0.1.2
  - encryption: 1.3.1
  - external: true
  - federatedfilesharing: 0.3.1
  - federation: 0.1.0
  - files: 1.5.1
  - files_antivirus: 0.11.2
  - files_clipboard: 0.6.2
  - files_external: 0.7.1
  - files_external_dropbox: 1.0.0
  - files_external_ftp: 0.2.0
  - files_pdfviewer: 0.8.2
  - files_sharing: 0.10.1
  - files_texteditor: 2.2.1
  - files_trashbin: 0.9.1
  - files_versions: 1.3.0
  - files_videoplayer: 0.9.8
  - firstrunwizard: 1.1
  - gallery: 16.0.2
  - gpxedit: 0.0.7
  - gpxmotion: 0.0.5
  - gpxpod: 2.2.1
  - guests: 0.5.0
  - market: 0.2.3
  - music: 0.5.5
  - notifications: 0.3.2
  - ownbackup: 17.7.0
  - phonetrack: 0.0.8
  - provisioning_api: 0.5.0
  - richdocuments: 1.1.27
  - security: 0.0.2
  - systemtags: 0.3.0
  - tasks: 0.9.3
  - templateeditor: 0.1
  - theme-example: 1.0.0
  - updatenotification: 0.2.1
  - user_external: 0.4
  - user_ldap: 0.9.1
  - xmas: 0.0.3

Are you using external storage, if yes which one: dropbox

Are you using encryption: yes
Are you using an external user-backend, if yes which one: WebDav (on my personal computer)

Client configuration

Debian 9.3 Stretch

Logs

ownCloud log (data/owncloud.log)

{"reqId":"NjHX8bGdyuuyjRfDbf7Z","level":3,"time":"2017-12-13T14:11:27+00:00","remoteAddr":"IP of my personal computer","user":"tchokapix","app":"PHP","method":"GET","url":"\/ocs\/v2.php\/ap\
ps\/notifications\/api\/v1\/notifications?format=json","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommende\
d instead. at \/var\/www\/owncloud\/lib\/composer\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18"}

So my server gets the request of my personal computer. I installed php7.0-intl on the server but I have still the same issues.