External Storage Issues

Steps to reproduce

  1. Storage type Local option is not showing u

Expected behaviour

Should see Local in the drop down

Actual behaviour

Local is missing

Server configuration

Operating system:
Raspberry Pi 4Stock Raspbian linu

Web server:
Apache2

Database:
Mariadb

PHP version:
PHP 7.3
ownCloud version: (see ownCloud admin page)

installed 1
maintenance
needsDbUpgrade
version 10.6.0.5
versionstring 10.6.0
edition Community
productname ownCloud
hostname raspberrypi

Updated from an older ownCloud or fresh install:
no

Where did you install ownCloud from:
from owncloud webpage

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

No errors have been found.

The content of config/config.php:

<<<< NEW USER UNABLE TO ATTACH FILES>>>>

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

I have tried most of the fixes.

including the

‘files_external_allow_new_local’ => true,

in the config.php file.

am able to mount the external hard drive.

external drive:

  • Type 1TB usb

  • erased and formatted it

  • fs type ext4

  • mounting is all good

  • RPi4 discovers it without any issue when i umount and reinsert it

  • Just that adding the external drive does not show up on the admin account.

thanks in advance
Raj

“Local” doesn’t show up under Settings->Admin->Storage?

Correct, it does not .

This is really strange. After you have added

‘files_external_allow_new_local’ => true,

to your config.php, you should be able to add your local mount point.

Screenshot from 2021-02-18 19-48-52

Yes, I added the parameter below.

‘files_external_allow_new_local’ => true,

But it still does not show up in the drop down.

also rebooted the RPi a couple of times.

You’re sure you have added this line to the correct config.php in effect? Not a sample or an inactive copy of it?

BTW, you don’t have reboot after changes in config.php to apply.

1 Like

OK Now. I see it. I had rebooted a couple of times last night before trying this.
Now I rebooted again and it shows up.

Thanks for the heads up on the config.php not requiring reboot.

Let me try remounting the drive, thats misbehaving now. It took me a few days to get to this state, let’s hope I can get it to work :).

Raj /\

Good luck! Hope you’ll be successful.

However, I am still not sure why it was not showing up after updating the config.php . Reboot should have worked, but did not.

oh wait… maybe my browser was still caching ??? That could have been an issue. I’ll keep this in mind for any future troubleshooting.

Thanks much! /\

1 Like

Hi Alfred,

the issue appeared again after I needed to reinstall owncloud due to an fstab issue.

Am not able to add an external disk as
‘Local’ does not appear in the dropdown.

The last time I am not really sure the combination of things that worked. Other than the fact that I rebooted it a few times. And quite frankly waited overnight for the changes to take place.

Thanks
Raj /\

Good Morning Rai,

After the reinstall, you have a ‘clean’ config.php. So you’ll have to add

files_external_allow_create_new_local’ => true,

again. Reload the page and you’re done, hopefully. :wink:

1 Like

Yes, I had done that :slight_smile:

Still no luck. Any othe setting other than enabling external drive?

None that I kow of. unless your you’re logged in as regular user than as admin.

logged in as admin.

I dont know what I did differently last time other than let it simmer overnight and come back the next day :slight_smile:

This is still an issue. Not sure what the problem is.

Any thoughts on debugging?

Fixed!

The flag is called:

files_external_allow_create_new_local’ => true,

not

files_external_allow_new_local’ => true,

:pray: :blush:

2 Likes