External Storage Redirect to Homepage

help

#1

So I'm running the latest version of Owncloud on a Raspberry Pi with Apache. I'm trying to set up external storage, and everything seems to work fine, all the dots are green, and I can see the drives in the external storage section. The problem starts when I click on the drive, it just redirects me to my homepage. I have no idea what is wrong, but I was hoping that somebody might know. Thanks in advance!
Steps to reproduce
1. Not 100% sure, but seems to be an issue with drive permissions.
2.
3.

Expected behaviour
Tell us what should happen
I should be able to open the drive and view the files, as I have some saved on there from past installations on an older Pi.
Actual behaviour
Tell us what happens instead
As soon as I try to access the drive, it automatically redirects me to my files homepage.
Server configuration
Operating system: Debian
Web server: Apache
Database:SQLite
PHP version: Latest
ownCloud version (see ownCloud admin page):9.1.1
Updated from an older ownCloud or fresh install: Fresh
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):
None
ownCloud log (data/owncloud.log)
owncloud.log (128.7 KB)

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info

Error
PHP
stat(): stat failed for /media/pi/clouddrivea/ at /var/www/owncloud/lib/private/Files/Storage/Local.php#133
2016-10-16T19:19:25+00:00
Error
PHP
filesize(): stat failed for /media/pi/clouddrived/ at /var/www/owncloud/lib/private/LargeFileHelper.php#196
2016-10-16T19:19:24+00:00
Error
PHP
stat(): stat failed for /media/pi/clouddrived/ at /var/www/owncloud/lib/private/Files/Storage/Local.php#133
2016-10-16T19:19:24+00:00
Error
PHP
filesize(): stat failed for /media/pi/clouddrivea/ at /var/www/owncloud/lib/private/LargeFileHelper.php#196
2016-10-16T19:19:24+00:00
Error
PHP
stat(): stat failed for /media/pi/clouddrivea/ at /var/www/owncloud/lib/private/Files/Storage/Local.php#133
2016-10-16T19:19:24+00:00
Error
PHP
filesize(): stat failed for /media/pi/clouddrivec/ at /var/www/owncloud/lib/private/LargeFileHelper.php#196
2016-10-16T19:19:23+00:00
Error
PHP
stat(): stat failed for /media/pi/clouddrivec/ at /var/www/owncloud/lib/private/Files/Storage/Local.php#133
2016-10-16T19:19:23+00:00
Error
PHP
filesize(): stat failed for /media/pi/clouddrived/ at /var/www/owncloud/lib/private/LargeFileHelper.php#196
2016-10-16T19:19:23+00:00

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here. 
No errors have been found.

#2

Here is a link to the video of the problem.

Click Here


#3

Ok, so some progress, I've been able to set up the drives so I am o longer redirected, but I have a new problem, I can view the files in the drives, but cannot add or change files. It simply says that I don't have permissions to upload or create files here. I have tried to troubleshoot this myself, through RealRancor's FAQ post, and through running

sudo -u www-data ls -la /path/to/folder (obviously with my folder path)

I have found no errors. I will include below what I have in my fstab file and hopefully that can provide some insight. They are USB flash drives formatted as FAT32.

/dev/sdc1 /media/cda vfat nls=iso8859-1,permissions,users,auto
/dev/sdd1 /media/cdb vfat nls=iso8859-1,permissions,users,auto
/dev/sdb1 /media/cdc vfat nls=iso8859-1,permissions,users,auto
/dev/sda1 /media/cdd vfat nls=iso8859-1,permissions,users,auto

I am also planning on trying to use

-o rw,umask=0000

after vfat instead of

nls=iso8859-1,permissions,users,auto

I'll update this thread if that works.

Thanks for the help!


#4

Just for the record,

-o rw,umask=0000

did not work for me. it actually began to mess with the on-board WIFI chip.


#5

Ok, progress, I'm able to upload now, it turns out that the drives had to be formatted as ntfs with

nls=iso8859-1,permissions,users,auto

in order to work. So, I'm trying to upload some files now and when I upload them, it gives me an error.

Upload failed. Could not find uploaded file.

What does this mean? Does anybody know how to fix it?
Thanks!


#6

Hi RWwarner

have you already tried to mount your vfat with option "uid=www-data,gid=www-data"?

Regards
Timm


#7

Yes I just did, it doesn't appear to work.


#8

Ok, more progress, I was able to get the drives mounted and they are readable by www-data, as mentioned in RearRancor's FAQ, now the error I am getting is

You don't have permission to upload or create files here.

I have read over the FAQ post multiple times and I don't know if I'm just doing something wrong, but maybe someone else can help me.

This is my fstab entry

/dev/sdb1 /media/cda vfat defaults,nofail 0 0
/dev/sdc1 /media/cdb vfat defaults,nofail 0 0
/dev/sda1 /media/cdc vfat defaults,nofail 0 0

I have nofail as an option because of a mounting issue in Raspbian where it boots into emergency mode.

Again, I can read and write to it, permissions are 777, I have set strong directory permissions, does anyone know what is going on?


#9

Different question: Do you really want to use FAT32?
If you use this storage only for owncloud, I would rather choose a native linux filesystem.


#10

Well, at this point I did not know how to format the drives as a native Linux fs, I was using my windows laptop to format them and obviously could not format them as such from there. I recently learned how to format the drives as EXT4, and I have everything set up so that it should work, it is readable and writable by other users (www-data) and still I get the error, You don't have permission to upload or create files here. I think that at this point if I can make it work, I will be happy. I think I am so close!
Thanks for the help!


#11

If it is a native Linux-fs, our FAQ should help you: