External Storage - ReFS Filesystem

expert
possible_bug
9.0.x
help

#1

(Sorry for repost, other post crashes all webbrowsers I try from and I cannot delete it)
Had the problem ever since the share was migrated from old disk volume to the new disk volume.
ownCloud versions tested with. 9.0.2 and 9.0.4
Cannot get access to external storage when the fileserver is formatted with ReFS.
Also the red/green status lights are not working the way they should.
The new ReFS formatted volume got it's data via robocopy, and all the shares where moved manually from old to new.

As long as SMB/CIFS uses saved credentials in user session it seems to show green light in administrator view.

Steps to reproduce
1. Setup a fileshare with partition type ReFS
2. Set up the share in External Storage from admin section
3. Even if the light get green it is not accessible

Expected behaviour
Should be able to access the fileshare same way as with NTFS shares.
On another server, Plex server also on Ubuntu 14.04 the same share is mounted in Ubuntu and works correctly, so i guess it is a problem with the "External Storage" app within ownCloud?

Actual behaviour
The shares shows in main page, but when clicked an error message "storage not available" comes up in the top.

Server configuration
Operating system: Ubuntu 14.04.4 LTS
Web server: Virtualmin 5.03
Database: MySQL 5.5.50
PHP version: 5.5.9-1ubuntu4.17
ownCloud version (see ownCloud admin page): 9.0.4
Updated from an older ownCloud or fresh install: 9.0.2
ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808):
Exception:
{"Exception":"OCP\Files\StorageNotAvailableException","Message":"Invalid
login","Code":0,"Trace":"#0
\/home\/tekniskmultimedia\/domains\/owncloud.tekniskmultimedia.no\/public_html\/apps\/files_external\/lib\/smb.php(157):
OC\Files\Storage\SMB->getFileInfo('')\n#1
\/home\/tekniskmultimedia\/domains\/owncloud.tekniskmultimedia.no\/public_html\/lib\/private\/files\/storage\/common.php(434):
OC\Files\Storage\SMB->stat('')\n#2
\/home\/tekniskmultimedia\/domains\/owncloud.tekniskmultimedia.no\/public_html\/apps\/files_external\/lib\/smb.php(391):
OC\Files\Storage\Common->test()\n#3
\/home\/tekniskmultimedia\/domains\/owncloud.tekniskmultimedia.no\/public_html\/apps\/files_external\/lib\/config.php(231):
OC\Files\Storage\SMB->test(false, false)\n#4
\/home\/tekniskmultimedia\/domains\/owncloud.tekniskmultimedia.no\/public_html\/apps\/files_external\/controller\/storagescontroller.php(258):
OC_Mount_Config::getBackendStatus('\OC\Files\Stora...', Array,
false, false)\n#5
\/home\/tekniskmultimedia\/domains\/owncloud.tekniskmultimedia.no\/public_html\/apps\/files_external\/controller\/userglobalstoragescontroller.php(118):

OCA\Files_External\Controller\StoragesController->updateStorageStatus(Object(OCA\Files_external\Lib\StorageConfig),
false)\n#6 [internal function]:
OCA\Files_External\Controller\UserGlobalStoragesController->show(5,
false)\n#7
\/home\/tekniskmultimedia\/domains\/owncloud.tekniskmultimedia.no\/public_html\/lib\/private\/appframework\/http\/dispatcher.php(159):
call_user_func_array(Array, Array)\n#8
\/home\/tekniskmultimedia\/domains\/owncloud.tekniskmultimedia.no\/public_html\/lib\/private\/appframework\/http\/dispatcher.php(89):

OC\AppFramework\Http\Dispatcher->executeController(Object(OCA\Files_External\Controller\UserGlobalStoragesController),
'show')\n#9
\/home\/tekniskmultimedia\/domains\/owncloud.tekniskmultimedia.no\/public_html\/lib\/private\/appframework\/app.php(110):

OC\AppFramework\Http\Dispatcher->dispatch(Object(OCA\Files_External\Controller\UserGlobalStoragesController),
'show')\n#10
\/home\/tekniskmultimedia\/domains\/owncloud.tekniskmultimedia.no\/public_html\/lib\/private\/appframework\/routing\/routeactionhandler.php(45):
OC\AppFramework\App::main('UserGlobalStora...', 'show',
Object(OC\AppFramework\DependencyInjection\DIContainer), Array)\n#11
[internal function]:
OC\AppFramework\routing\RouteActionHandler->__invoke(Array)\n#12
\/home\/tekniskmultimedia\/domains\/owncloud.tekniskmultimedia.no\/public_html\/lib\/private\/route\/router.php(276):
call_user_func(Object(OC\AppFramework\routing\RouteActionHandler),
Array)\n#13
\/home\/tekniskmultimedia\/domains\/owncloud.tekniskmultimedia.no\/public_html\/lib\/base.php(907):
OC\Route\Router->match('\/apps\/files_ext...')\n#14
\/home\/tekniskmultimedia\/domains\/owncloud.tekniskmultimedia.no\/public_html\/index.php(39):
OC::handleRequest()\n#15
{main}","File":"\/home\/tekniskmultimedia\/domains\/owncloud.tekniskmultimedia.no\/public_html\/apps\/files_external\/lib\/smb.php","Line":119}

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):
- Shared hosting on own webserver.

Integrity status for oC9+
No issues found


#2

Do you see any errors on the smb-server?


#3

No errors, only "audit seccess" and a red light in owncloud.
If i remove the domain in owncloud it sometimes get a green light, but with a "audit failure" on the fileserver.
I even tried to use the local administrator account, but that did not help.

Same server with a volume formatted with NTFS works without any problems.
Maybe the External Storage plugin are not able to check permissions for a folder with ReFS?

Here is also a screenshot of the module with the shares mounted at the same time, one with ReFS and one with NTFS.

I tried the same on another server as well, the domain controller. Made a volume with ReFS and mounted. That way all the accounts should be able to connect without use of domain, but that did not work either.
I guess nobody are able to connect to a share with ReFS formatting since results are pretty consistant.


#4

It's a bit sad that no one seem to know the solution for this. I was hoping to get the attention of the programmer that made the extension in the first place.

I am certain of the problem, and i am certain that there is no configuration errors. Also the ReFS filesystem will probably be implemented many places soon. I just converted as I was curious of the benefits of ReFS.

Hope some smart people would like to have a look at the problem :slight_smile:


#5

oC developers are getting slowly active here. If you think this is an issue in oC itself you can directly create a bugreport at https://github.com/owncloud/core/issues


#6

But is it a core issue? I tought the extensions might be outside OwnCloud core? And External Files looks like a extension to me.


#7

No, it's a core feature. Only files_primary_swift and files_external_ftp have their own repos: https://github.com/owncloud/?utf8=%E2%9C%93&query=files_