External Storage Support "storage not available" error

external_storage
help

#1

Hello, all.

I recently attempted upgrading my ownCloud instance from 8.0.2 to 9.1.0. The main problem I ran into was that users could not see external storage that I had set up for one of our NAS servers, even though I had added back all of the shares in the External Storage Support plugin. Using the "Log-in Credentials, save-in session" would not work at all; nor would "User name and password" pointing to a domain admin account. User A logs in, can see their shares, but when they click on a share, it throws an error: "Storage not available." I ended up having to rollback my snapshot to 8.0.2 prevent work stoppage.

Any thoughts or ideas?


#2

What kind of external storage do you use?

In case of errors, you should always look in your logfiles. You've seen this problem when you passed through the other major versions (8.1, 8.2, and 9.0)?


#3

I upgraded from 8.0.2 to 9.1.0 in one night. I didn't try remounting the storage until 9.1.0 was installed. I am using SMB/CIFS with OC Logon option for connecting storage in 8.0.2, which is working. But in 9.1.0, I chose "Log-in Credentials, Save-in Session" and it never worked. I tried "User name and Password" at one point, which actually allowed the storage to be recognized by ownCloud, but it never allowed them to mount. It kept throwing the "Storage not available" error.

Which log in particular are you referring to that I should be checking? The ownCloud.log log in /var/log is always empty when I look at it.


#4

By default, owncloud logs to /path/to/owncloud/data/owncloud.log.

owncloud.log and your webserver-log are of special interest. Regarding SMB-storages, there are a few fixes for the next release of OC 9.0 and 9.1, so I would wait a few days. Or you just upgrade to 8.2.x for the moment.


#5

Fair enough. Are the upcoming patch's patch notes out yet?


#6

There are some remarks in the announcement for the release candidates:


#7

Also make sure you're using https://github.com/eduardok/libsmbclient-php and not the smbclient binary


#8

@RealRancor

I attempted upgrading again last night from 8.0.1 to 9.1.1 (community version) and ran into the exact same problem -- even after following your recommendation of installing libsmbclient-php. ownCloud will detect my external storage, but not its contents. When you click on any external share folder, it says "No files here".


#9

@RealRancor

I'm wondering if some of the ownCloud binaries and/or configuration files are getting clobbered from doing so many in place upgrades instead of just installing 9.1 or 9.2 fresh. Thoughts?


#10

Then just report a bug to the bugtracker...


#11