Failed to request notifications

9.1.x
help

#1

Can you help me with this error please
For the moment I only refresh the interfaces and it gives me this notification and I unconfigure all the interfaces of owncloud and if I continue refreshing it gives me an error forbbiden 403 and leaves the web inaccecible to me.

Failed to request notifications. Please try to refresh the page manually. This operation is prohibited


Error 403 Forbbiden
#2

You need to help us first by filling out the issue template shown when creating a new thread in the "oC server" category. Up to now its not even known which ownCloud version you're running so why do you think some one might be able to help here?

The issue template is asking you various information about your environment which are needed to help here.


#3

I am sorry, but I do not see any template to enter the data you comment, if this information is important, the annex below:

SW. Debian jesse 8
Linux owncloud 3.16.0-4-amd64 # 1 SMP Debian 3.16.36-1 + deb8u2 (2016-10-19) x86_64 GNU / Linux
PHP 5.6.27-0 + deb8u1 (cli) (built: Oct 15 2016 15:53:28)
Mysql View 15.1 Distrib 10.0.27-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2
Server version: Apache / 2.4.10 (Debian)
Server built: Sep 15 2016 20:44:43

Owncloud Server

  • installed: true
    • version: 9.1.1.3
    • versionstring: 9.1.1
    • edition:

Enabled:
- activity: 2.3.2
- audioplayer: 1.2.2
- calendar: 1.4.0
- comments: 0.3.0
- contacts: 1.4.0.0
- dav: 0.2.6
- documents: 0.13.1
- encryption: 1.3.0
- federatedfilesharing: 0.3.0
- files: 1.5.1
- files_antivirus: 0.9.0.0
- files_pdfviewer: 0.8.1
- files_sharing: 0.10.0
- files_texteditor: 2.1
- files_trashbin: 0.9.0
- files_versions: 1.3.0
- files_videoplayer: 0.9.8
- firstrunwizard: 1.1
- gallery: 15.0.0
- notifications: 0.3.0
- ownbackup: 0.3.8
- rainloop: 4.27
- systemtags: 0.3.0
- tasks: 0.9.3
- templateeditor: 0.1
- twofactor_totp: 0.4.1
- updatenotification: 0.2.1
Disabled:
- external
federation
- files_external
- provisioning_api
- richdocuments
- user_external
- user_ldap

App is compliant - awesome job!

THANKS YOU


#4

You have quite a lot 3rdparty apps enabled. A first starting point would be to disable all these.

Updating to ownCloud 9.1.2 which was released yesterday is another thing you should do.


#5

Still does not allow me to update to 9.1.2, tells me that I have the latest version installed, and disable many plugins, but my error continues, I show my configuration:

sudo -u www-data php occ config:list
{
"system": {
"instanceid": "ockx2cbcto3u",
"passwordsalt": "REMOVED SENSITIVE VALUE",
"secret": "REMOVED SENSITIVE VALUE",
"trusted_domains": [
"REMOVED SENSITIVE VALUE"
],
"datadirectory": "REMOVED SENSITIVE VALUE",
"overwrite.cli.url": "REMOVED SENSITIVE VALUE",
"dbtype": "mysql",
"version": "9.1.1.3",
"dbname": "REMOVED SENSITIVE VALUE",
"dbhost": "REMOVED SENSITIVE VALUE",
"dbtableprefix": "oc_",
"dbuser": "REMOVED SENSITIVE VALUE",
"dbpassword": "REMOVED SENSITIVE VALUE",
"logtimezone": "UTC",
"installed": true,
"loglevel": 0,
"memcache.local": "\OC\Memcache\APCu",
"mail_smtpmode": "smtp",
"mail_from_address": "owncloud",
"mail_domain": "REMOVED SENSITIVE VALUE",
"mail_smtphost": "REMOVED SENSITIVE VALUE",
"mail_smtpport": "REMOVED SENSITIVE VALUE",
"preview_libreoffice_path": "\/usr\/bin\/libreoffice",
"preview_office_cl_parameters": " --headless --nologo --nofirststartwizard --invisible --norestore -convert-to pdf -outdir ",
"enabledPreviewProviders": [
"OC\Preview\PNG",
"OC\Preview\JPEG",
"OC\Preview\GIF",
"OC\Preview\BMP",
"OC\Preview\XBitmap",
"OC\Preview\MP3",
"OC\Preview\TXT",
"OC\Preview\MarkDown"
],
"enable_previews": true,
"preview_max_scale_factor": 10,
"preview_max_filesize_image": 50,
"appstoreenabled": true,
"appstoreurl": "https:\/\/api.owncloud.com\/v1",
"appstore.experimental.enabled": true,
"apps_paths": [
{
"path": "REMOVED SENSITIVE VALUE",
"url": "\/apps",
"writable": true
}
],
"appcodechecker": true,
"maintenance": false,
"singleuser": false,
"trashbin_retention_obligation": "D+15",
"Session_lifetime": 300,
"Session_keepalive": true,
"ldapIgnoreNamingRules": false,
"knowledgebaseenabled": true
},


#6

Do a manual update and don't rely on updater app. Once you're using a recent oC version we can continue here.


#7

You should also remove all that senseless stuff from your config.php:


"preview_libreoffice_path": "\/usr\/bin\/libreoffice",
"preview_office_cl_parameters": " --headless --nologo --nofirststartwizard --invisible --norestore -convert-to pdf -outdir ",
"appstoreenabled": true,
"appstoreurl": "https:\/\/api.owncloud.com\/v1",
"apps_paths": [
{
"path": "REMOVED SENSITIVE VALUE",
"url": "\/apps",
"writable": true
}
],
"appcodechecker": true,
"singleuser": false,
"Session_lifetime": 300,
"Session_keepalive": true,
"ldapIgnoreNamingRules": false,
"knowledgebaseenabled": true

Only add stuff into the config.php which you want to actually change from the defaults listen in the config.sample.php. Thats documented at various places.


#8

I can not connect to my smtp server, I can not connect the Documents app to the path of libreoffice, and several of my previous app can no longer use them because they are not compatible = (, I send them owncloud data again.

sudo -u www-data php occ status
- installed: true
- version: 9.1.2.5
- versionstring: 9.1.2
- edition:

sudo -u www-data php occ app:list
Enabled:
- activity: 2.3.2
- comments: 0.3.0
- dav: 0.2.7
- documents: 0.13.1
- encryption: 1.3.0
- federatedfilesharing: 0.3.0
- files: 1.5.1
- files_antivirus: 0.9.0.0
- files_pdfviewer: 0.8.1
- files_sharing: 0.10.0
- files_texteditor: 2.1
- files_trashbin: 0.9.0
- gallery: 15.0.0
- mail: true
- notifications: 0.3.0
- systemtags: 0.3.0
- updatenotification: 0.2.1
Disabled:
- external
- federation
- files_external
- files_versions
- files_videoplayer
- firstrunwizard
- provisioning_api
- templateeditor
- user_external
- user_ldap

sudo -u www-data php occ config:list
{
"system": {
"instanceid": "ockx2cbcto3u",
"passwordsalt": "REMOVED SENSITIVE VALUE",
"secret": "REMOVED SENSITIVE VALUE",
"trusted_domains": [
"REMOVED SENSITIVE VALUE"
],
"datadirectory": "REMOVED SENSITIVE VALUE",
"overwrite.cli.url": "REMOVED SENSITIVE VALUE",
"dbtype": "mysql",
"version": "9.1.2.5",
"dbname": "REMOVED SENSITIVE VALUE",
"dbhost": "REMOVED SENSITIVE VALUE",
"dbtableprefix": "oc_",
"dbuser": "REMOVED SENSITIVE VALUE",
"dbpassword": "REMOVED SENSITIVE VALUE",
"logtimezone": "UTC",
"installed": true,
"loglevel": 2,
"memcache.local": "\OC\Memcache\APCu",
"mail_smtpmode": "smtp",
"mail_from_address": "owncloud",
"mail_domain": "REMOVED SENSITIVE VALUE",
"mail_smtphost": "REMOVED SENSITIVE VALUE",
"mail_smtpport": "25",
"preview_libreoffice_path": "\/usr\/bin\/libreoffice",
"enabledPreviewProviders": [
"OC\Preview\PNG",
"OC\Preview\JPEG",
"OC\Preview\GIF",
"OC\Preview\BMP",
"OC\Preview\XBitmap",
"OC\Preview\MP3",
"OC\Preview\TXT",
"OC\Preview\MarkDown"
],
"enable_previews": true,
"preview_max_scale_factor": 10,
"preview_max_filesize_image": 50,
"theme": ""
},


#9

Error PHP Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. at Unknown#0 2016-11-13T18:10:04+00:00

Error index Exception: {"Exception":"Exception","Message":"Authenticated ciphertext could not be decoded.","Code":0,"Trace":"#0 \/var\/www\/html\/apps\/mail\/lib\/account.php(383): OC\Security\Crypto->decrypt(*** sensitive parameters replaced ***)\n#1 \/var\/www\/html\/apps\/mail\/lib\/account.php(205): OCA\Mail\Account->createTransport()\n#2 \/var\/www\/html\/apps\/mail\/lib\/controller\/accountscontroller.php(333): OCA\Mail\Account->sendMessage(Object(OCA\Mail\Model\Message), 27)\n#3 [internal function]: OCA\Mail\Controller\AccountsController->send(1, NULL, 'Fwd: prueba', '\n\n\n-------- Men...', '\"Shalon Teran -...', '', '', 27, NULL, NULL, '')\n#4 \/var\/www\/html\/lib\/private\/AppFramework\/Http\/Dispatcher.php(159): call_user_func_array(Array, Array)\n#5 \/var\/www\/html\/lib\/private\/AppFramework\/Http\/Dispatcher.php(89): OC\AppFramework\Http\Dispatcher->executeController(Object(OCA\Mail\Controller\AccountsController), 'send')\n#6 \/var\/www\/html\/lib\/private\/AppFramework\/App.php(99): OC\AppFramework\Http\Dispatcher->dispatch(Object(OCA\Mail\Controller\AccountsController), 'send')\n#7 \/var\/www\/html\/lib\/private\/AppFramework\/Routing\/RouteActionHandler.php(46): OC\AppFramework\App::main('AccountsControl...', 'send', Object(OC\AppFramework\DependencyInjection\DIContainer), Array)\n#8 [internal function]: OC\AppFramework\Routing\RouteActionHandler->_invoke(Array)\n#9 \/var\/www\/html\/lib\/private\/Route\/Router.php(280): calluser_func(Object(OC\AppFramework\Routing\RouteActionHandler), Array)\n#10 \/var\/www\/html\/lib\/base.php(891): OC\Route\Router->match('\/apps\/mail\/acco...')\n#11 \/var\/www\/html\/index.php(54): OC::handleRequest()\n#12 {main}","File":"\/var\/www\/html\/lib\/private\/Security\/Crypto.php","Line":118}