Federated sharing with spaces in usernames

known_bug
9.0.x
help

#1

Hi all,

I am trying to share a directory with a user on another ownCloud server. However, this user has a space in his username (Firstname Lastname). So, instead of sharing the directory with username@urltoowncloudserver.com (which works, we've tried with another user without spaces), it seems I should share it with Firstname Lastname@urltoowncloudserver.com. My problem is that this URL is not accepted by my ownCloud server. What is the correct way (if any) to share with this user?


#2

I tried to reproduce your error @demaratus but for me it works:

  • create shared folder on server1 (OC 8.2)
  • share folder with my user@server2/nextcloud (NC 10)

(both on debian 8, apache, php7 from dotdeb)

Can you give more information about the OC versions being used and the configuration?


#3

Both servers are running raspbian on raspberry pi 3. Apache and php are installed from the default repositories. The ownCloud version is in both cases 9.0.0.

Here is a screenshot of my situation:

Without the space in the username, the input field gives me a dropdown that I can select to share the folder. With the space, I get the error message (in Dutch) "no users or groups found".

Is there any specific information I can provide?


#4

Can you update to a current version which would be 9.0.4?


#5

I have updated my server to 9.0.4 and still no luck in sharing my folder. I'm now waiting for my friend to update his server, since I don't have access to it.

I will come back to you once this is finished. Thanks already for the help so far!


#6

Just a quick note, I should have mentioned this in my initial post: both servers are accessed through the pagekite system (www.pagekite.net).


#7

Wait, I think I found a 9.0.x system and try to reproduce it...


#8

So I had a setup on my raspberry pi. I can reproduce this error with version OC 9.0.4 and with OC 9.0.5RC1 as well.

Sharing to my user@example.org/nextcloud (nextcloud 10):
OC 8.2.7 -> ok
OC 9.0.4 -> failed
OC 9.0.5RC1 -> failed

sorry, I currently have no test setup on OC 9.1 which I can use for tests.

@demaratus: Please open a bug report on github.com/owncloud/core/issues


#9

The bug report is here: https://github.com/owncloud/core/issues/25955. In the future I may upgrade to 9.1 and see if the issue also exists there, but currently I have no time.

Thanks for the help!


#10

The bug is also in OC 9.1. The fix for OC 9.0.x is here:


and will be included in OC 9.0.6.