Fedora 25, Nginx, Mariadb

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

Steps to reproduce
1. Have Fedora25 server, dnf update, dnf clean
2. dnf install owncloud-nginx owncloud-mysql mariadb-server
3. systemctl enable mariadb.service
4. mysql_secure_installation
5. edit /etc/nginx.conf point server root to /usr/share/owncloud
6. systemctl enable php-fpm, systemctl start php-fpm
7. access owncloud, login and see 404 message

Expected behaviour
Owncloud should be functional

Actual behaviour
get 404 message with the URL http://$hostname/index.php/apps/files/ 404 Not Found

Server configuration
Operating system: Fedora 25
Web server: nginx
Database: mariadb
PHP version: 7.0.14-1.fc25
ownCloud version (see ownCloud admin page): owncloud.noarch 9.1.3-1.fc25
Updated from an older ownCloud or fresh install: no
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): no

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info

Integrity status for oC9+

Login as admin user into your ownCloud and access
paste the results here.
404 not found


the Fedora packages are not provided by the ownCloud community so you might not find that much user familiar with those in here.

If you don't get an answer here get in touch with a community like http://fedoraforum.org/ where you can find more people having the knowledge to help you.

An alternative would be the nginx support channels linked here: https://nginx.org/en/support.html as this looks also more just like a nginx setup problem with your config.

This doesn't appear to be an issue with Fedora since the web server and OS are both running fine - although there is one post on Fedora forums with the same problem that has gone unanswered for over two years.

If anything it looks like php is the culprit, however i'm nowhere near au fait with php to even know where to start troubleshooting.

I will check through nginx support, thanks.

As you're also on nginx make sure that you're running the nginx config provided here:


Other (default) configs won't work