File sharing doesn't work anymore after manual upgrade to 10.7.0

Hello,

I did a successful manual upgrade of owncloud server to version 10.7.0.4.
Just before that upgrade, I successfully created a public share on a folder.
Now (after the upgrade) that I want to edit this share and let’s say add an expiration date, it seems broken. No sharing option is displayed.

Steps to reproduce

  1. Log in to owncloud in Files view
  2. Click the share link next to the folder
  3. The sidebar opens on the “Sharing” tab
  4. Nothing is displayed, only the running circle keeps moving permanently

Expected behaviour

the sharing options should be displayed, to be able to add/edit/remove a share

Actual behaviour

Nothing is displayed except the “loading” circle that keeps turning.

Server configuration

Operating system:
Debian GNU/Linux 9

Web server:
Apache/2.4.46

Database:
MySQL 5.7

PHP version:
7.4

ownCloud version: (see ownCloud admin page)
10.7.0.4

Updated from an older ownCloud or fresh install:
updated

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):
No errors have been found.

The content of config/config.php:

{
“system”: {
“instanceid”: “”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
“REMOVED”
],
“datadirectory”: REMOVED,
“overwrite.cli.url”: REMOVED,
“dbtype”: “mysql”,
“version”: “10.7.0.4”,
“dbname”: REMOVED,
“dbhost”: REMOVED,
“dbtableprefix”: “z6cl_”,
“mysql.utf8mb4”: true,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“logtimezone”: “UTC”,
“installed”: true,
“theme”: “”,
“loglevel”: 2,
“maintenance”: false,
“filelocking.enabled”: true,
“mail_domain”: “REMOVED SENSITIVE VALUE”,
“mail_from_address”: “REMOVED SENSITIVE VALUE”,
“mail_smtpmode”: “php”,
“updater.secret”: “REMOVED SENSITIVE VALUE”,
“memcache.local”: “\OC\Memcache\APCu”,
“memcache.locking”: “\OC\Memcache\Redis”,
“redis”: {
“host”: “localhost”,
“port”: 6379
}
}
}

List of activated apps:

owncloudEnabled:

  • activity:
    • Version: 2.6.0
    • Path: /owncloud/apps/activity
  • comments:
    • Version: 0.3.0
    • Path: /owncloud/apps/comments
  • configreport:
    • Version: 0.2.0
    • Path: /owncloud/apps/configreport
  • dav:
    • Version: 0.6.0
    • Path: /owncloud/apps/dav
  • federatedfilesharing:
    • Version: 0.5.0
    • Path: /owncloud/apps/federatedfilesharing
  • federation:
    • Version: 0.1.0
    • Path: /owncloud/apps/federation
  • files:
    • Version: 1.5.2
    • Path: /owncloud/apps/files
  • files_external:
    • Version: 0.7.1
    • Path: /owncloud/apps/files_external
  • files_mediaviewer:
    • Version: 1.0.4
    • Path: /owncloud/apps/files_mediaviewer
  • files_pdfviewer:
    • Version: 0.12.0
    • Path: /owncloud/apps/files_pdfviewer
  • files_sharing:
    • Version: 0.14.0
    • Path: /owncloud/apps/files_sharing
  • files_texteditor:
    • Version: 2.3.0
    • Path: /owncloud/apps/files_texteditor
  • files_trashbin:
    • Version: 0.9.1
    • Path: /owncloud/apps/files_trashbin
  • firstrunwizard:
    • Version: 1.2.0
    • Path: /owncloud/apps/firstrunwizard
  • gallery:
    • Version: 16.1.1
    • Path: /owncloud/apps/gallery
  • market:
    • Version: 0.6.0
    • Path: /owncloud/apps/market
  • notifications:
    • Version: 0.5.2
    • Path: /owncloud/apps/notifications
  • provisioning_api:
    • Version: 0.5.0
    • Path: /owncloud/apps/provisioning_api
  • systemtags:
    • Version: 0.3.0
    • Path: /owncloud/apps/systemtags
  • twofactor_totp:
    • Version: 0.7.1
    • Path: /owncloud/apps/twofactor_totp
  • updatenotification:
    • Version: 0.2.1
    • Path: /owncloud/apps/updatenotification
      Disabled:
  • admin_audit:
    • Path: /owncloud/apps/admin_audit
  • announcementcenter:
    • Path: /owncloud/apps/announcementcenter
  • customgroups:
    • Path: /owncloud/apps/customgroups
  • encryption:
    • Path: /owncloud/apps/encryption
  • enterprise_key:
    • Path: /owncloud/apps/enterprise_key
  • external:
    • Path: /owncloud/apps/external
  • files_antivirus:
    • Path: /owncloud/apps/files_antivirus
  • files_classifier:
    • Path: /owncloud/apps/files_classifier
  • files_external_dropbox:
    • Path: /owncloud/apps/files_external_dropbox
  • files_external_ftp:
    • Path: /owncloud/apps/files_external_ftp
  • files_ldap_home:
    • Path: /owncloud/apps/files_ldap_home
  • files_lifecycle:
    • Path: /owncloud/apps/files_lifecycle
  • files_versions:
    • Path: /owncloud/apps/files_versions
  • firewall:
    • Path: /owncloud/apps/firewall
  • graphapi:
    • Path: /owncloud/apps/graphapi
  • guests:
    • Path: /owncloud/apps/guests
  • metrics:
    • Path: /owncloud/apps/metrics
  • oauth2:
    • Path: /owncloud/apps/oauth2
  • openidconnect:
    • Path: /owncloud/apps/openidconnect
  • password_policy:
    • Path: /owncloud/apps/password_policy
  • ransomware_protection:
    • Path: /owncloud/apps/ransomware_protection
  • sharepoint:
    • Path: /owncloud/apps/sharepoint
  • systemtags_management:
    • Path: /owncloud/apps/systemtags_management
  • templateeditor:
    • Path: /owncloud/apps/templateeditor
  • theme-enterprise:
    • Path: /owncloud/apps/theme-enterprise
  • user_external:
    • Path: /owncloud/apps/user_external
  • user_ldap:
    • Path: /owncloud/apps/user_ldap
  • user_shibboleth:
    • Path: /owncloud/apps/user_shibboleth
  • web:
    • Path: /owncloud/apps/web
  • windows_network_drive:
    • Path: /owncloud/apps/windows_network_drive
  • wopi:
    • Path: /owncloud/apps/wopi
  • workflow:
    • Path: /owncloud/apps/workflow

Are you using external storage, if yes which one: no

Are you using encryption: no

Are you using an external user-backend, if yes which one: no

Client configuration

Browser:
Firefox
Operating system:
macOs Big Sur

Logs

Web server error log

no error

ownCloud log (data/owncloud.log)

no info, warning, error or fatal issue found in the log file when reproducing the issue.

Browser log

n/a

Sounds like something went wrong during the update.

Please describe your update process.

I followed the guidelines from here:
https://doc.owncloud.com/server/admin_manual/maintenance/manual_upgrade.html

I customized the process according to my settings of course (folder names etc) but other than that, no other “special” steps.

Thanks for your feedback !

@dmitry one thing though: apache was not stopped/started in the process. Could it be an issue ?

I don’t think so.

So the issue is just this one public link you can’t edit?

New public links work fine?

no, no sharing is possible. I cannot add/modify/delete any share.
One more piece of info: the reason why I upgraded in the first place is that I got this error when trying the automatic update through the web interface:

Server error response [url] https://localhost/index.php/occ/config:list [status code] 503 [reason phrase] Service unavailable

Could it be related to an underlying cause ?

seems strange. When did you get that response? What were you trying to do?

Do occ commands work now on your server?

Yes, occ commands work.

So what I did in chronological order:

  1. I tried to upgrade to the latest owncloud version, using the “Open updater” button in the general settings
  2. Instead of the updater running its checks etc, I got that message:
    Server error response [url] https://localhost/index.php/occ/config:list [status code] 503 [reason phrase] Service unavailable
  3. Then I decided to go for a manual upgrade and followed steps found on owncloud.org
  4. It went fine, except that sharing is not working anymore (circle is permanently running)

And I have the same error (in 2.) on other owncloud installs on the same server (that’s where the screenshot comes from)

Hm, okay. Did you try the web updater first on the other instances as well?

yes, I have 3 other owncloud installs on the same cloud server waiting for update.
I tried to update them all using the web updater, and they all give the same error.

I tried one more thing on the problematic install. I changed the channel to “daily” in order to have the web updater button again.
When I try it, it also gives the same error again:
Server error response [url] https://localhost/index.php/occ/config:list [status code] 503 [reason phrase] Service unavailable

Yeah, the web updater should never be used to upgrade ownCloud. Manual upgrade is the way to go. We state this in our documentation.

But the sharing issue is really weird.

may I ask if you have an enterprise license? The Windows Network drives app is enterprise only.

No enterprise license.
I probably installed that a long time ago for testing I guess.

Web updater worked fine up until now :wink:

it’s always a roll of the dice with the updater :]

Do you see any messages in the log file that would point you somewhere?

1 Like

no :sob:
Unless you have another idea, I’ll look around again before I change all the owncloud installs …

Sharing settings?

@eneubauer But updating shouldn’t turn off sharing, right?

1 Like

That is correct, but this is the first thing to check anyway.

Yeah, maybe the OP has disabled the Share Files app before upgrading.

files_sharing is listed in the enabled apps list though

1 Like