File upload - gateway timeout problem

upload_limit
help

#1

Hi,

I edited the user.ini file as well as php,ini of the site with optimal values as suggested by owncloud manual pages, however still uploading even a 250 MB file returns in a gate-way time out error.

Please check http://elentech.com/Filemanagement/info.php for my current php settings of the site, am i missing something ?


#2

Hi,

if you have a look at the ownCloud manual there are way more config options causing such timeouts then the ones in .user.ini and php.ini. There is also a another FAQ available here providing additional info:


#3

HI,

I checked all the settings, still issue persists,
I set up session_keepalive to true in config.php, this is the user.ini file contents

upload_max_filesize=6G
post_max_size=6G
memory_limit=6G
mbstring.func_overload=0
always_populate_raw_post_data=-1
default_charset='UTF-8'
output_buffering=0
max_execution_time= 21600
max_input_time= 21600

Even a 120 MB file gets the gateway time out error after upload, however when i log off and log in again , the uploaded file is there, so it is certainly a script timeout, but i am not sure where is the settings.


#4

As recommended please read the documentation as well as the linked FAQ. There are various settings involved here, not only the PHP ones (e.g. webserver timeout settings etc.).

If unsure contact the support of your hoster about this issue. They might have additional knowledge about your issue.

You should also be aware that you're running ownCloud on CGI/FastCGI. ownCloud is not tested and is unsupported on such an environment. You're mostly on your own when hitting such issues as long as no one with a similar setup is able to help you how to fix your webservers config.