File upload terminates at 48kb every time

Hi everyone,

I’ve been successfully using ownCloud for many years now, but for some reason, recently, I cannot upload files larger than a certain size to my ownCloud server.

The desktop client gives up on the upload after sending 48kb of data (exactly this amount, every time), and when I ssh into the server and check the folder, a .part file is present, with a size of 32 kb.

I’ve just tried upgrading to the latest version of both the server and the Windows client, and I have looked in to php.ini upload limits, etc., and I disabled the apache security module, but nothing seems to work. The log file reports that a checksum mismatch occurred on the file (not surprising, as it got truncated to 32 kb.

I’m basically looking for clues now, as I am out of ideas. Surely something is cutting off the upload at 32 kb (or 48 kb - depending on whether we believe the ownCloud client or the .part file).

Does anyone have any ideas about what the culprit might be?


Have you checked the available disk space in your data folder and where your PHP tmp is pointing to?

Otherwise, we need to know more about your environment in order to effectively help you. When creating a new server topic there should be a template with all the relevant questions. Not sure why you neglected to fill that out, so please do it know.

Thanks for the response - I figured that info wouldn’t help, but you’re right, I should’ve filled it in.

Anyway, I found the solution, so I thought I’d write here for anyone else.

My Windows desktop client locates my server using a URL, so there’s a DNS lookup involved when it connects. The DNS resolves to a public IP, naturally. However, my client (a laptop) is currently connected to my home network, so I guess traffic is routed out of my house, then back in again (? don’t know - I’m guessing here).

Apparently, this structure is fine for small files (less than around 32 kb), but something breaks it for larger files.

I fixed it by inserting a rule in my Windows hosts file to map the URL directly to the server’s IP on my internal home network. I will need to manually remove that rule when I take my laptop outside the house, otherwise it won’t work outside.

Interestingly, I could always upload files perfectly using the web client, but I think this supports the thesis, as I was accessing the web page by internal network IP, not URL.

Thank you for your time!

1 Like

Now you always have to remember where you are and whether you need the hosts file entry or not.

Perhaps your router on your home network is also your DNS server and allows you to add a DNS entry to overwrite the public IP address result in there. That why you don’t need to constantly change the hosts file.

This is most likely a restriction of the router, some deal better others worse in this situation. Though I also do find it very interesting that the website keeps working, but client doesn’t.

Glad you found out what it was, and you are right in this case the template wouldn’t have helped. However you also didn’t mention that the WebUI keeps working in your initial post :wink: