File versions fills my small webspace


#1

Steps to reproduce

  1. Just having some files on the server and wait

Expected behaviour

File versions should only be generated when something changes

Actual behaviour

According to the documentation file versions are generated every minutes, days, weeks but shouldn’t fill up my webspace which it does.

Server configuration

Operating system:
Ubuntu 18.4

Web server:
Apache

PHP version: 7.2.15

ownCloud version: 10.0.10

I think that should give enough information.
I’ve stopped file versions for now but I think they only make sense to make a new version if something changed.


#2

I don’t think so. Something within your environment seems to disturb file versioning.


#3

My config file:

<?php
$CONFIG = array (
  'instanceid' => '//////////////////////////////////////////////////////////',
  'passwordsalt' => '/////////////////////////////////////////////////////',
  'secret' => '/////////////////////////////////////////////////////////////////',
  'trusted_domains' =>
  array (
          0 => '..................',
          1 => '................'
  ),
  'datadirectory' => '/var/www/html/owncloud/data',
  'overwrite.cli.url' => 'http://............/owncloud',
  'dbtype' => 'mysql',
  'version' => '10.0.10.4',
  'dbname' => 'owncloud',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'ownclouduser',
  'dbpassword' => '---------------------',
  'logtimezone' => 'UTC',
  'installed' => true,
  'versions_retention_obligation' => '7,14',
);

My main point is that the file versioning system isn’t reasonable in my opinion. I turned file versioning off now. So hope that works.


#4

Hmm, beside many others, I don’t have any problem with the file versioning.
OK, I didn’t tweak the settings. :grin:


#5

Hey,

i’m using the file version since longer time and this doesn’t happen here in my ownCloud installation as well. Very strange, maybe there is something in your environment changing these files so that ownCloud thinks they have changed?