Files in folders on clients are not displayed

Hi! I observe a problem, some files are not displayed on desktop clients.
Instead, I see empty folders in which these files should be located.
At the same time, these files are visible and accessible in the web interface.

In order for the files to be displayed in an empty folder, it is enough for me to
create an empty file in this folder and wait for synchronization.
After that, all the files that should be in this folder are displayed.

I tried running scan commands for all users on the server, but it didn’t help.

All clients use a virtual file system.

Сlient: Windows 10 Pro
Owncloud client: 4.2.0
Server: Ubuntu
Owncloud server: 10.11
PHP: 7.4.33
PHP APCu: 5.1.22
Redis: 5.3.7
Apache2: 2.7.4
Mysql: 5.7.26

Hey,

it seems ownCloud 10.11.0 has been released more then a year ago (on 2022-08-23) and ownCloud 10.13.1 is the current version (released on 2023-09-04).

Maybe you can try to update the version to a more up to date one to see if this got already solved?

1 Like

Hi!
Yes, I can do it in the next few days. But it seems to me that this is not the problem, since everything is displayed well on the iOS, Android, Web client, and I observe the problem only on Windows with the owncloud 4.2.0 client installed.
I also want to add that forced synchronization on the client does not help.
I also noticed that the log file on the server is empty.

Hi!
I updated the server to version 10.13.1, after which I made “oсс files:scan --all”,
but this did not help solve my problem. I still don’t see some files in folders
on my computer with the 4.2.0 client installed. At the same time, these files
are visible through the web and through mobile clients.
Please any tips!

I’m not using the desktop client, but isn’t there something in its config, that avoids the sync of particular files?

2 Likes

no, this is not related to the prohibition on synchronizing certain files on my part. the problem is something else. Tell me how to understand what the problem is?

I haven’t been able to solve this problem yet, even considering upgrading the client to version 5. What other information can I provide?

Сlient: Windows 10 Pro / Windows Server 2022
Owncloud client: 5.0.0.12278
Server: Ubuntu Server
Owncloud server: 10.13.2
PHP: 7.4.33
PHP APCu: 5.1.22
Redis: 5.3.7
Apache2: 2.7.4
Mysql: 5.7.26

Hey,

if this is an issue in the client itself then i think it maybe is required to open an issue below and the ownCloud people could better say what additional info is required: