First steps to Calendar sync

help

#1

I doubt this is a server problem, rather, it is a user ignorance problem. Can I get a pointer to the right document, or a list of the basic steps to sync calendars between the ownCloud calendar app and the Android calendar app? Never have used either app before.

Steps to reproduce
1. Created an admin account after installing ownCloud.
2. Created a user account for me personally (don).
3. Logged into the ownCloud server as don.
4. Created an event on the Personal calendar.
5. Fired up CalDAV-Sync on the phone.
6. Added new account.
7. Fired up Calendar app on the phone.

Expected behaviour
The newly-created appointment on the server calendar, appears on the phone calendar.

Actual behaviour
Phone displays an empty calendar. However, if I try to create a calendar event on the phone, I get a message that I must add a calendar.

Server configuration
Operating system: Linux don-desktop 4.5.0-1-amd64 #1 SMP Debian 4.5.1-1 (2016-04-14) x86_64
Web server:Apache/2.4.25 (Debian)
Database:mysql
PHP version:5.6.24-0+deb8u1
ownCloud version (see ownCloud admin page):9.1.3
Updated from an older ownCloud or fresh install:fresh
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):none

ownCloud log (data/owncloud.log)
(empty log)

Integrity status for oC9+

No errors have been found.

Client configuration
Android version 4.4.2 / 19
Android Calendar app 4.4.2-eng.bp_sync.20160310.113228
calDAV-Sync 0.4.27-Amazon


#2

There's room for a lot of mistakes in your step 6. The problem probably lies somewhere in there.

Basically, if you can see your event in the ownCloud Calendar app in the web interface, and you set up CalDAV-Sync correctly, and it has already successfully synchronized once, then you shold see it in the Google Calendar app on your Android device.

You should double-check CalDAV-Sync's own instructions first. Then, also test some other CalDAV client (e.g., emClient, Apple Calendar, etc.) as well to see if that works.

Make sure you're using the right CalDAV URL. It should be in the format "https://example.com/remote.php/dav/"


#3

Pazu's correct, "Added a new account" is quite vague and likely to be your problem.

I originally used CardDav-Sync (sister app to CalDav-Sync) myself, and while it's quite good, it's documentation leaves a little to be desired. I switched to "Easy Dav for Owncloud" and it works for both contacts and calendars brilliantly.

Not that you should give up or anything, but if first you don't succeed, there are plenty more apps in the store (and there are plenty more stores on the 'net!)


#4

Solving technical problems is all about asking the right question, right?

More detail: I open the CalDAV Sync app on the phone, and click "Add new account." Given a menu of options like CalDAV, WebCal, GMX, mailbox.org, etc, I choose CalDAV. I am prompted for a server URL, which is https://192.168.0.65/remote.php/dav. I hit "Next," and I get a message that the certificate is untrusted. Dismissing that, I see a list of calendars to sync, and the only calendar on the list is Personal. Looks good so far; clearly the phone is communicating with ownCloud.

I'm prompted for the email address associated with the account, and enter it. I leave "Sync from server to phone only" unchecked, and hit "Finish." It says "Congratulations." Woo. I set the sync interval to 10 minutes because why not.

When I open the phone's Calendar app, the calendar is empty. I hit the menu button and hit "Calendars to display" (an empty list), then "Calendars to sync," which contains one calendar named Local and it is marked "not synced."

Perhaps this is closer to the right question: Shouldn't I see a calendar named Personal?


#5

You can check the FAQ in [1], especially the hint about the litmus test which you can use if your webserver / environment is configured correctly for such a sync setup. If this is correctly configured and the litmus test is not failing you might to either want to contact the author of CalDAV sync to ask for support [2] or switch to DAVDroid which is known to work with ownCloud.

[1]

[2] http://dmfs.org/?contact

[3] https://davdroid.bitfire.at/


#6

Make sure in android calendar app you have selected your CalDav account to display.