Fixed on 10.0.3 ? - MySQL - 1071 Specified key was too long while installing 10.0.2


#1

Hello,

A week ago I was trying to install ownCloud 10.0.2 using Softaculous auto installer and I got the error:

MYSQL: 1071 Specified key was too long.

I was going to try to upload it manually ... maybe it was a problem with Softaculous ! but before doing that I contacted my web host and they told me:

Currently ownCloud cannot be installed on our system as it does not meet our MySQL terms.
Please check this one: https://github.com/owncloud/core/issues/28007

So ... it was promised that the problem is going to be fixed on ownCloud 10.0.3 , and ownCloud 10.0.3 is already released some days ago !

So is the problem fixed before uploading this very large script?

Thanks! :slight_smile:


#2

Indeed is it, my good sir :slight_smile:


#3

I really took time to upload and at last I got the same problem :frowning: :frowning: :frowning:

Specifcied key was too long max key is 1000 bytes


#4

I opened the "core/Migrations" folder and found a lot of PHP files ...
I opened all those files and replaced 255 with 55 and now I get:

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

Technical details

Remote Address: 188.114.102.133
Request ID: WcGOrV3sspfGsSNBzEIWIgAAACA

When I try to create the admin account.

:frowning:


#5

I tried to use SQLite instead of my SQL server and successfully created the admin account .. but when I try to login now I get :

Access forbidden
CSRF check failed

:frowning:


#6

Sadly all the solutions to fix the "CSRF check failed" error is to configure the webserver for ownCloud :frowning:
I can't do that... Goodbye ownCloud! the older versions worked fine :weary:


#7

Can you tell me how you tried to install ownCloud?


#8

@mariolatif741 Can you show us the output from when you installed ownCloud - this should tell us which key is failing still. The other option is to install on a mysql server without strit mode enabled (which is the default actually) which will not fail on this error.