Forbidden to Download or Access any files

10
webserver_issue

#1

Steps to reproduce

  1. Go to my owncloud10 address on browser
  2. Login
  3. Try to download any file
  4. error message shows "Forbidden"
  5. Try to upload any file
  6. error message shows "Forbidden"

Expected behaviour

Able to download and upload without any issues

Actual behaviour

Not able to download, or upload ANY files.

Server configuration

Operating system: Fedora 25 (Running Amahi)

Web server: Apache\/2.4.27 (Fedora) PHP\/7.0.24 Phusion_Passenger\/5.0.30

Database:

PHP version:

ownCloud version: 10.0.4.4

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from: amahi web apps

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

https://gist.github.com/anonymous/f9ff5a06632fc4e53e819c2c6656bd68

The content of config/config.php: https://gist.github.com/anonymous/69eadd2284c3b8e376d980fe1bc73b23

List of activated apps:

Are you using encryption: no

Client configuration

Browser: Firefox 58.0

Operating system: Windows 10

Logs

ownCloud log (data/owncloud.log)

https://gist.github.com/anonymous/ee00c5942e49721e9fabb055e1094dac

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

#2

Can you check the permissions on you data dir?


#3

this is the permissions on the data folder!

drwxrwx--- 9 apache users 4096 Nov  9 20:29 data

doesnt look like a problem with the permissions now.. :frowning:


#4

Does your DB User has the right permissions?

Can you check your logs for clues? (i.e. Error messages)


#5

Can you please advise how should I check for the DB User permission??

My owncloud log shows this error message:
failed to open stream: No such file or directory at \/var\/hda\/web-apps\/owncloud10\/html\/lib\/private\/Files\/Storage\/Local.php#213"


#6

https://dev.mysql.com/doc/refman/5.7/en/show-grants.html

Can you tell me how you installed owncloud? Did you follow a guide?

Do you have your files stored locally or on a external storage?


#7

I am not getting any output from the mysql SHOW GRANTS command, not sure how to get it to work.

I've installed owncloud through http://www.amahi.org/apps/owncloud, following the guide https://wiki.amahi.org/index.php/OwnCloud_on_Amahi

My files are stored on a second HDD in my server. I have set that up properly and was running fine until yesterday when I was trying to configure remote access by adding my dynamic DNS address into the "trusted domains". After getting the trusted domain to work, I have lost the ability to download, upload or access any files. (through any domains, wether the dynamic dns address (external) or via server ip address (local))


#8

Do you have access to a command line?


#9

Yup I do, however i cannot figure out the password for root for mysql..


#10

is you don't set it its emply, so "mysql -uroot" should give you access

can you also check your sites-availible folder in your etc/apache2/ folder

I think you need the owncloud.conf


#11

This is my 1000-owncloud10.conf within /etc/httpd/conf.d


#12

drwxrwx--- 9 apache users 4096 Nov 9 20:29 data

change that to apache apache


#13

I've changed it to apache apache using chown apache:apache but still no avail.

drwxrwx--- 9 apache apache 4096 Nov 9 20:29 data

sorry for the late response, i was away!


#14

I tried creating a new account on my owncloud and - I can now upload and access files! What could be the issue? my old files on my old account are now inaccessible though.. :frowning:

edit: certain accounts are working fine, but not all.


#15

Can you change the rights recursive?


#16

done, still the same. It doesnt say Forbidden when i try to download the file, now it just says Not Found on a plaintext owncloud page.


#17

On the same account, I can now create a new folder and upload within the folder itself, as well as the root folder itself (which was previously forbidden). However, my files from the other folders are still non-accessable.