Force SMB Version for External Storage

I realize this is partially owncloud, partially ubuntu, but is there a way to force owncloud to use SMB2 or greater when connecting to a windows external share? I can connect to any external share on a server that still allows SMB1, but any with SMB1 disabled is failing. I can connect in linux if I specify the SMB version but I can’t seem to find a way to do that in owncloud. I’ve edited the smb.conf with min and max client protocol but it still failing to connect in owncloud.

Any thoughts? I can include more info about my setup if needed, I left it out as the issue seems to be pretty specifically I just need to get owncloud to use SMB2.

1 Like

Are you sure you’ve edited the file right? It’s client min protocol and client max protocol options.
In addition, it’s highly recommended to install the libsmbclient-php library (https://github.com/eduardok/libsmbclient-php). I’m not sure if there are packages for that library or you’ll need to compile it by yourself

Thank you for the response, I do have libsmbclient-php installed. Also, below is the exact lines from my smb.conf file.

workgroup = WORKGROUP
client min protocol = SMB2
client max protocol = SMB3

Well, interestingly enough i did find a workaround here (odd since this references a very old version and I’m on the latest release - although I believe its more of a config on the linux side than the owncloud side):

Like in the comments, it works if I use the DFS path rather than the server DNS name or IP address. I’m not sure why that is the case but its working so I’m happy! Hopefully this helps out anyone else with the issue.

1 Like

what is your smbclient version you have?

If you have the smbclient version 4.7-, update it to newest or at least the 4.8+ version.

Looks like i’m on 4.7.6. I will attempt to update this evening.

1 Like

Please do it and let me know the results :slight_smile: