Fresh Installation errors

hosting

#1

Hi
I have this error
/dev/urandom is not readable by PHP which is highly discouraged for security reasons. Further information can be found in our documentation.

I have set up a Google Cloud server with an installation of Debian and VestaCP to handle the web and the Let's Encrypt certificate
I used the PHP installation script
I have sorted HSTS and redirect http to https errors in the .htaccess file

This is one of the last 2 errors I am trying to sort

I have looked in the documentation... but the php.ini file has open_basedir commented out with a ; and so it is not in use
I have tried putting it in use with the line suggested but nothing changes... although not sure I have typed it correctly
All back to original state of the open_basedir not being used

I'd love some advice on this if anyone has any

Also the VM has only 1 domain allocated to it... so it will be for one organisation only.... sub.domain.co.uk and is a root installation so going there takes you straight to the OC login in page (no subfolders)

thanks

Tristan


#2

open_basedir is just one of many things which could cause this. Stuff like SELInux or just wrong linux/unix permissions are a few other examples.


#3

Hi

Yes that is what I wrote in the question.. as the documentation states that

however I also wrote that

in the php.ini and .user.ini file "open_basedir" is not used... it is commented out with the ";" so that shouldn't be the problem and I have tried using it... but does nothing

As for permissions on the folder... ok? what permissions? what folder? how do I set these? there is no walkthrough guide on this!!

I have also stated I am using Debian for the Linux OS and VestaCP for the webcontrol panel

Tristan


#4

Answering such questions within the documentation of ownCloud is not possible. One system might need permissions where another systems needs completely different permissions / access rights.

Solving this issue needs basic linux knowledge of the admin maintaining the ownCloud installation.

Generic hints are available in [1]. To solve this issue the user running your webserver needs access and read permissions to the /dev/urandom special device.

[1]
https://doc.owncloud.org/server/latest/admin_manual/configuration_server/harden_server.html#dev-urandom-label