Fresh OCX server, many problems

I have used OC9 some time ago and it worked very well. Then migrated to Nextcloud just to check it out, but it did not work at all for some reaon - JS libraries did not load no matter how hard I tried to configure them, their forums were not helpful as well. So I came back to OC, and since version 10 was released in the meantime, I happily installed it afresh to a new, clean database. However, I did encounter several problems and/or bugs.

  1. I cannot share any files with a public link (as it is described as a new feature of version 10.). The only way I can share is to other server users. Do I have enable public sharing somehow?
  2. I have quite a lot extra files and invalid hashes. I have spent like an hour deleting extra files and downloading (mostly JS library) files to fix the incorrect hah popup. After that the top yellow popup disappeared but only for a while - just a refresh or two later the files came back, or the scanner foundseveral dozen more extra files. That was a completely fresh install, I have tried twice. Right now I simply disabled the popup via config, as it simplly annoyed me.
  3. After installing Calendar app from market - it displayed blank screen. Isn't it that apps are confirmed to work with current release to be put into the marketplace?
  4. Performance seems slightly worse than in 9., I do use MySQL, but no memcaching, etc.; is it my server's fault or simply OCX eats up more resources?
  5. Cannot install "Contacts" app. Pressing INSTALL does not result in anything happening.

Server configuration

Operating system:
Linux 4.1.2; shared hosting
Web server:
Apache 2.0
PHP version:
ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:
Official webpage, web UI install

Signing status (ownCloud 9.0 and above):

I have made some edits to template files, but they are only cosmetic - a simple customisation for easier use, it does not interefere anything really

The content of config/config.php: (remove spaces, I had a link amount restriction for the post)
htt ps:/ /gist.github. com/anonymous/1cd1104b7ea09acb558d9da2d920ecd6

List of activated apps:
htt ps:/ /gist.github. com/anonymous/bf4ba958f563757249bb14e323e6307c

Are you using external storage, if yes which one:

Are you using encryption:

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/...

Client configuration

Firefox 53

Operating system:
Windows 10 (most probably very recent build)


Web server error log

no error.log generated anywhere

ownCloud log (data/owncloud.log)

Browser log

Content Security Policy: Dyrektywa „frame-src” jest przestarzała. Zamiast niej należy używać dyrektywy „child-src”. (nieznane)
JQMIGRATE: Migrate is installed with logging active, version 1.4.0 jquery-migrate.min.js:1:150
SyntaxError: unterminated regular expression literal bowser.js:32:123
JQMIGRATE: is deprecated jquery-migrate.min.js:4:258
console.trace(): jquery-migrate.min.js:4
migrateWarn http s://igment. com/chmura/core/vendor/jquery-migrate/jquery-migrate.min.js:4:329 http s://igment. com/chmura/core/vendor/jquery-migrate/jquery-migrate.min.js:46:69
http s://igment. com/chmura/apps/firstrunwizard/js/firstrunwizard.js:2:1
"You are running Vue in development mode.
Make sure to turn on production mode when deploying for production.
See more tips at" guests.bundle.js:1:94860
SoundManager V2.97a.20170601 (HTML5-only mode) soundmanager2-jsmin.js:1:10556
SoundManager 2 HTML5 support: mp3 = true, mp4 = true, ogg = true, opus = true, wav = true, flac = true soundmanager2-jsmin.js:1:10556
SoundManager 2: Ready. ✓

I just have checked my OCX installation and have none of these *.min.js files. Looks like something on your server is adding those behind ownclouds back and is causing your seen issue. This could also explain why you see the same issue on nextcloud and owncloud.

Please have a look at the admin settings for sharing

Why are you downloading libs? Just use the code as we ship it.

Works for me and thousand of users - never heard of an issue like that.

10.0.3 holds quite some performance optimizations. Furthermore memcaching is encouraged as well as using php 7 with opscache

Most likly because there are a hell of issues with your installation generally. Get the issues above sorted out first.

Thank you for the reply.
I have struggled and struggled, installing to separate directories, trying 10.0.2 but finally made a step ahead. I made an error by downloading the zip via ssh wget command, unzipping and moving the content of the owncloud directory one level up with mv * .. . Problem was that .htaccess and .user.ini were not moved and installation seemed to be successful but some parts of it failed. Right now, I unzipped and ran the setup without moving files and it fixed the problem with hash and extra files. Also, Contacts app works well.

Unfortunately, Calendar app still does not work. Here's the screenhot of what I see when I enter the Calendar app.

Here's console log of file page wgen trying to share:

Also, here's the screenshot of my "sharing" settings section - I think everything related to public haring is enabled, yet when I go to the "share" menu of a file, I can only see alert.
http s://i.i (remove spaces)
Here's console log:

The ReferenceError: bowser is not defined[Więcej informacji] sharedialogview.js:10:1210 alert pops up when I press the Sharing tab in the file panel. Seems like the bowser fails to be loaded.

Any ideas?

which browser are you using?

This seems to be the common issue ....

1 Like

Firefox 53 says as above mentioned, most important console lines in this case:
1. Reason for why bowser is not loaded:
SyntaxError: unterminated regular expression literal bowser.js:32:123
2. Bowser cannot be loaded and so when I press the 'share' tab, this pops up:
ReferenceError: bowser is not defined[Więcej informacji] sharedialogview.js:10:1210

MS Edge says as below:

Looks like some unexpected happens on line 32? That's how the line looks like in bowser.min.js:
else if(webos){result={name:'WebOS',webos:t,version:versionIdentifier||getFirstMatch(/w(?:eb)?osbrowser\/(\d+(\.\d+)?)/i)};/touchpad\}
It does in fact look a bit weird after the semicolon, yet I am not too fluent in JS. Can you check if your file looks the same on this line?
directory: \core\vendor\bowser\src\bowser.min.js

Performance issue fixed - only my Firefox seem to lag badly. Seems like it needs some cleaning! But hey, OC is lighning-fast on fresh browsers, great!

There is no such file on my fresh ownCloud 10.0.3 installation and also not in

Are you really sure that this is not the main cause of all your issues as already asked in

1 Like

Thank you a lot! Finally I have found out the culprit. Thing is that I have some scss and js processors configured in the directory above the one with owncloud and I have misconfigured them - they have also manipulated files that were within the owncloud directory, although they should not have. Thus the JS files being minimized and weird files being created.

Thanks and my apologies for my ignorance about what happens on my hosting. My regards, have a fine night!

1 Like