FTP External storage issue - no logs


#1

Server configuration

Operating system: Debian 8.9 64bits
Web server: Apache2
Database: MariaDB
PHP version: 7.0.23
ownCloud version: 10.0.0.3
Updated from an older ownCloud or fresh install: Fresh Install
Where did you install ownCloud from: https://owncloud.org/

My Issue

Hello there, I have a FTP on my ISP Box and I have this url to access it :
URL : ftpes://mylogin@mydomain.isp.com:38669
So, I used :
Login: mylogin
Password : mypassword
Host : mydomain.isp.com
Port : 38669

But this is not working. I tried to use "Secure with ftps://", I tried to use "ftpes://mydomain.isp.com" in the Host entry, still nothing. Red square.

My iptables rules :
iptables -t filter -A OUTPUT -p tcp --dport 38669 -j ACCEPT
iptables --append INPUT --protocol tcp --dport 27601 --jump ACCEPT ## PASV Port

The weird thing, I tried it two days ago, and I got some logs :

"message":"ftp_ssl_connect(): php_network_getaddresses: getaddrinfo failed: Name or service not known at \/var\/www\/owncloud\/lib\/composer\/league\/flysystem\/src\/Adapter\/Ftp.php#112"}
=> But I was able to ping mydomain.isp.com, and tried to add in the /etc/hosts file
mydomain.isp.com my-ip
But still nothing, so I removed it.

But then I tried it again yesterday and today, but I have 0 logs about ftp in owncloud. Absolutely NOTHING.

I ask for some advices !


#2

Up ? I have made 0 advancements...


#3

Did you check if it works without the iptables rules? If it works you'll likely have a problem with the iptables rules.


#4

Tried without the iptables rules, no changes.


#5

Related to a bug : https://github.com/owncloud/files_external_ftp/issues/17
Closing this thread.