FullTextSearch app in owncloud 10.0.10

Hi,

Operating system Ubuntu 18.04.1 LTS
ownCloud version 10.0.10

I am using my owncloud 10.0.10. This version does not support FullTextSearch. This application will be applied when you owncloud 10.0.10 version. does anyone knows?

There was a delay with the release.
The app should be out soon for beta testing. So stay tuned :slight_smile:

1 Like

Thank you for the information

Has a date been announced about the application? This application is important for us

Beta App for testing:
https://customer.owncloud.com/owncloud/index.php/s/uHAuH1CPIUwRnsL

Readme
https://customer.owncloud.com/owncloud/index.php/s/SPJg6MQi3r3Mxwe

3 Likes

I don’t understand how to install “elastic search app”. Can you answer the following questions

  1. The “elastic search app” will be installed on the owncloud server or installed on another server.?
  2. “https: //customer.owncloud.com/owncloud/index.php/s/uHAuH1CPIUwRnsL” is the file installation file that we will download and how to install it
  3. Could you share detail for installation
  1. It’s an ownCloud app, so…
  2. Extract it under your apps folder
  3. The README mentioned above should give you all the required information.
1 Like

I read. here is just writing the information given below as “search elastic app”. I copied it into the apps file, but I didn’t see anything about this implementation in the admin settings. Do I have to do something after I copy?

Installation of search_elastic

  • install & enable the app
  • go to the admin settings, set up url and port, click “setup index”

The app you downloaded is just the plugin to ownCloud. For the search you need the elasticsearch server.

Quick question, if you have access to customer.owncloud.com - why don’t you contact support?

1 Like

I installed the “Elasticsearch” application. Then I made the steps in the Read me section and set up the elastic serach server. I changed the configuration setting as follows.
cluster.name: mycluster1
node.name: MyFirstNode
node.rack: r1
path.data: / path / to / data
path.logs: / path / to / logs
network.host: localhost
http.port: 9200

I ran the following command under elasticsearch-2.1.2 / bin.
./elasticsearch --cluster.name mycluster1 --node.name MyFirstNode

made a transaction like this

[2019-06-10 09: 35: 43,722] [WARN] [bootstrap] running as ROOT user. this is a bad idea!
[2019-06-10 09: 35: 44,310] [INFO] [node] [MyFirstNode] version [2.1.2], pid [21031], build [63c285e / 2016-01-27T12: 57: 52Z]
[2019-06-10 09: 35: 44,310] [INFO] [node] [MyFirstNode] initializing …
[2019-06-10 09: 35: 44,348] [INFO] [plugins] [MyFirstNode] loaded [], sites []
[2019-06-10 09: 35: 44,443] [INFO] [env] [MyFirstNode] using [1] data paths, mounts [[/ (/ dev / mapper / owncloud - vg-root)]], net usable_space [1.8tb], net total_space [1.9tb], spins? [possibly], types [ext4]
[2019-06-10 09: 35: 47,043] [INFO] [node] [MyFirstNode] initialized
[2019-06-10 09: 35: 47,043] [INFO] [node] [MyFirstNode] starting …
[2019-06-10 09: 35: 47,299] [INFO] [transport] [MyFirstNode] publish_address {localhost / 127.0.0.1: 9300}, bound_addresses {127.0.0.1:9300}, {[:: 1]: 9300}
[2019-06-10 09: 35: 47,309] [INFO] [discovery] [MyFirstNode] mycluster1 / 4QS80waTTHi6kpeJnWTtgQ
[2019-06-10 09: 35: 50,350] [INFO] [cluster.service] [MyFirstNode] new_master {MyFirstNode} {4QS80waTTHi6kpeJnWTtgQ} {127.0.0.1} {localhost / 127.0.0.1: 9300} {rack = r1}, reason: zen-disco-join (elected_as_master, [0] joins received)
[2019-06-10 09: 35: 50,363] [INFO] [http] [MyFirstNode] publish_address {localhost / 127.0.0.1: 9200}, bound_addresses {127.0.0.1:9200}, {[:: 1]: 9200}
[2019-06-10 09: 35: 50,364] [INFO] [node] [MyFirstNode] started
[2019-06-10 09: 35: 50,417] [INFO] [gateway] [MyFirstNode] recovered [0] indices into cluster_state

Then I entered the search section in the admin panel. but here I wrote elasticsearch server ip, but could not find any server.

elasticsearch-2.1.2 downloaded over the internet. I just extracted the zip file and installed the plugin you mentioned, I didn’t do any installation. Was it enough for me to do this?
Is elasticsearch server not working properly?

That seems contradictory. So did you do any installation or not? It would be clearer if you just write your steps in a bullet point fashion down instead of wording it confusingly.

I followed the steps at

https://www.elastic.co/guide/en/elasticsearch/reference/2.2/_installation.html