Gallery App doesn't work any more


after the last update of the gallery app (-> Version 16.1.0) the following error appears in the logfile:

“Class ‘Symfony\Component\Yaml\Parser’ not found at /var/www/html/owncloud/apps/gallery/config/configparser.php#94”

The error is caused by the missing folder ‘vendor’ in the correspondig app-folder of the gallery app - in other words, the symfony components could not be found.

I tried to copy the ‘vendor’ folder from a backup but that doens’t solve the problem.

What can I do?


the release of ownCloud 10.0.9 is just around the corner, and I believe there is a fix for the gallery app.

Could you wait and upgrade to 10.0.9 to see if the error persists?

Is this a shared file you are trying to open?


yes, I can wait for ownCloud 10.0.9 and test the gallery app again. But I believe that the fix has to be done in the gallery app itself, if the folder ‘vendor’ is missing in the package of the gallery app.

But let’s wait and see with the the upcoming version of ownCloud.

Many thanks

Hey, i have searched a little bit in the gallery app repository and stumbled over the following:

If i’m understanding the initial posted message correctly this “Symfony Parser” is indeed a library and the assumption “as we do not use any php libraries currently” might be wrong?

Not sure if this is something which gets solved on its own with ownCloud 10.0.9 so i think its probably better to create a new issue at the gallery issue tracker?

I think, it’s included ownCloud, so not needed to include to the app as well.

BTW, I have no trouble running exactly the same version of Gallery as the OP.

I havn’t seen the message as well but maybe we have a different setup (e.g. no configuration file for the gallery) then the OP.

Yes, it is the configuration - as soon as I rename my gallery config-file the gallery apps works fine. But for parsing the config-file the app definitly needs the symfony components which are not included any more.

1 Like

Are those app-specific config files still in use? I thought the apps are storing their config in the db table oc_appconfig now. But I may be wrong, of course.

So just waiting for the next version?

Or may exist a way to downgrade gallery?

How did you rename that file?

Anyway I reinstalled Gallery now works

But is too slow on loading photos

I got another owncloud with the prevoius version where I store 2 TB of HD photos

And is far much faster

I jusr renamed it from ‘gallery.cnf’ to ‘gallery_not_active.cnf’ - then it will not be found and the gallery works again.

In my case reeinstalling of the app doesn’t work. So I just wait for version 10.0.9. Does anyone know when 10.0.9 will be available as update? Up to now I don’t get any information in the ui that the update is available.

Hey, i’m still not sure if ownCloud 10.0.9 will fix this for you. I would still suggest to create an issue at the gallery app issue tracker to get this required library included again.

Today I upgraded to 10.0.9 - and the error is still there as soon as the file ‘gallery.cnf’ exists:

“message”:“Class ‘Symfony\Component\Yaml\Parser’ not found at /var/www/html/owncloud/apps/gallery/config/configparser.php#94”

For me, this is clearly a bug, worth opening an issue at

As I don’t have a cnf file for gallery, I’m curious what it contains. Could you post it here, if it is not too private?

I thought about the same, maybe the app developer hasn’t considered the .cnf config file parsing when removing this library. Thats why i had suggested to create a new bugreport two weeks ago. :slightly_smiling_face:

I had a look at the app wiki and it seems the file content is documented there at

@tom42 Thanks for the hint. It looks like gallery had a Settings-UI in earlier versions. I didn’t recognize that.

Here is the configuration - just some information regarding color and sorting:

# Gallery configuration file - do not touch
  external_shares: no
  native_svg: yes
  background_colour_toggle: yes
  background: "#E0FFFF"
  inherit: yes
  type: date
  order: des
  inherit: yes