Get error when installing Collabora(Virtual Machine)


#1

I’m following this guide step-by-step on a clean debian9 machine :

I perform the installation:

apt-get update && apt-get install loolwsd code-brand

And then loolwsd gets stopped

I can’t figure out what has gone wrong and why.

I ask you if I need additional configuration not shown in the guide.

My Owncloud runs in SSL.
Reverse proxy isn’t configured.


#2

Mhhh, isn't there some command for systemd showing the reason / additional logs why a service fails to start?


#3

Well, typing journalctl -xe I can even get less!

Maybe should I setup reverse proxy?


#4

Mhhh, i don't think that setting up an reverse proxy makes much sense if the service is not starting at all. :confused:


#5

I try to set static ip address


#6

I just have found out that there is a /etc/loolwsd/loolwsd.xml file in my installation which contains the possibility to enable logging to a file within the "" section. Maybe this could provide you some additional details why the service is not starting?


#7


I still don't get any log file.

Here's daemon.log


#8

The second screenshot is showing some permission issues on the loolwsd.log so i think this might be the reason why you don't get any logging for it.


#9

This file doesn't exits yet


#10

Yes, but i think it can't exist if the loolwsd doesn't have any permissions to create and write into it.


#11

how do I let the process write into that file?


#12

I think you need to setup the correct permissions for the service and the file to allow it to write into this file. Which permissions you need is probably something operation system specific.


#13


Now i got docker, does it look working?

I mean is it time to start with reverse proxy?


#14

I fixed this issue by installing a docker I suggest to everyone to do that way, it works and it's an even less wasting time method.