Gnome dropped status icons and ownCloud won't open (Fedora 27)

help

#1

Firstly, this is a Gnome change, not Fedora but I run Fedora 27. Gnome has decided to drop the status icon drawer and it has broken my access to the GUI. As far as I can tell ownCloud is still operating in the background syncing my files and the like.

There is a work around extension that moves all status icons to the Top Bar however ownCloud has ceased to open that way either, I can see the icon on the top bar but I have no access. I have done everything I can possibly think of and (obviously) I can't find a solution. The icon nor the application overall will respond any longer.

I'm out of ideas and I can't find any information in any release after 2.3.3 that seems to indicate a fix.

Fedora 27
Gnome 3.26
ownCloud 2.3.3 (Fedora hasn't pushed 2.3.4 yet for some reason?)


#2

Known issue - we are looking into options to fix that problem.


#3

You can always just open the GUI with the owncloud command on the command line. If the client is running - it will bring up the GUI. If the client is not running - it is started in the background. So just type the command and enjoy the GUI :wink:


#4

But the context menu is not accessible - we should work on a better solution.


#5

Please give this extension a try: https://extensions.gnome.org/extension/1031/topicons/


#6

hodyroff: I have tried opening the GUI that way before I made this thread, it doesn't work.

DeepDiver1975: I have tried that extension (and it's predecessor). That also doesn't work. It did at first but has since been broken, by what I don't know.

As long as the issue is known that is all I can ask. ownCloud is still running in the background and my folder updates. I just hope a remedy is found soon because it means that I either lose the app upon a OS reload or I cant reload until its fixed.


#7

Too bad .... any other known extension which might work with Gnome 3.26?


#8

Just to let you know, I tried the Topicons Plus extension you linked and it works just fine, I can click the icon and it opens the GUI.


#9

It is apparently glitchy on my side (the TopIcons Plus Extension). On my laptop it works flawlessly, not on my desktop. Some kind of loading problem on boot it seems, I log out and log back in and it works. Hopefully a permanent solution won't be far off so I can ditch this work around but all is in working order for now. Thanks for the help!


#10

killing and starting /usr/lib/x86_64-linux-gnu/indicator-application/indicator-application-service as the desktop session user (using an xterm console for example) seems to help most of the time:

killall indicator-application-service
/usr/lib/x86_64-linux-gnu/indicator-application/indicator-application-service & disown

(Discussion here: https://github.com/owncloud/client/issues/6518 )