Gpg apt error - BADSIG

Running Owncloud 10.4.1 on Debian 9, I noticed the repos changed to “…production” instead of “…stable…”
So I tried with either one, and had a gpg BADSIG error so I cleaned apt, removed the key re added it, but I still get the same error.

Does anyone have this error as well? and any advice if its a server or client error and how to fix it?

"
: GPG error: https://download.owncloud.org/download/repositories/production/Debian_9.0 Release: The following signatures were invalid: BADSIG 47AE7F72479BC94B ownCloud build service obsrun@localhost
W: The repository ‘http://download.owncloud.org/download/repositories/production/Debian_9.0 Release’ is not signed.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.

"
Cheers

1 Like

I’m getting the same error for Ubuntu 18.04.

Looking at the repository in my web browser (for both Ubuntu and Debian), I seen all of the files have been updated today (08-05-20) except for the Release.key, and Release.gpg (which were last updated 04-24-20).

Key seems ok until 2023, but somehow it is not recognized anymore and/or the repos are not signed correctly from the error message I’m getting.
"apt-key list
/etc/apt/trusted.gpg

pub rsa2048 2013-08-26 [SC] [expires: 2023-08-23]
DDA2 C105 C4B7 3A66 49AD 2BBD 47AE 7F72 479B C94B
uid [ unknown] ownCloud build service obsrun@localhost
sub rsa2048 2013-08-26 [E] [expires: 2023-08-23]
sub dsa2048 2013-08-26 [S] [expires: 2023-08-23]
"
Error:
"
: GPG error: https://download.owncloud.org/download/repositories/production/Debian_9.0 Release: The following signatures were invalid: BADSIG 47AE7F72479BC94B ownCloud build service obsrun@localhost
W: The repository ‘http://download.owncloud.org/download/repositories/production/Debian_9.0 Release’ is not signed.
"

Hey,

i think this is a duplicate posting of the following tipic GPG Error (Ubuntu 18.04 / 16.04 / ...) where the following info can be found:

closing as duplicate of GPG Error (Ubuntu 18.04 / 16.04 / ...)

1 Like