GPG apt key expired for 9.1 on Ubuntu 16.04

hosting

#1

Hello.
I have ownCloud 9.1 installation on CentOS 6.5 and am attempting to move it to a new server with Ubuntu 16.04. I thought the safest way would be to install ownCloud 9.1 on the new server, move data from the old server, and then upgrade owncloud on the new server. However I am getting GPG key errors when attempting to install 9.1 on the new server:

wget -nv (editing link due to new user limit)/repositories/9.1/Ubuntu_16.04/Release.key -O Release.key

sudo apt-key add - < Release.key

sudo apt-get update

Fetched 10.3 MB in 1s (6,687 kB/s)
Reading package lists… Done
W: GPG error: (editing link due to new user limit)repositories/9.1/Ubuntu_16.04 Release: The following signatures were invalid: KEYEXPIRED 1535163442 KEYEXPIRED 1535163442 KEYEXPIRED 1535163644 KEYEXPIRED 1535163442 KEYEXPIRED 1535163442 KEYEXPIRED 1535163442 KEYEXPIRED 1535163442 KEYEXPIRED 1535163644 KEYEXPIRED 1535163442
W: The repository ‘http://download.owncloud.org/download/repositories/9.1/Ubuntu_16.04 Release’ is not signed.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.


#2

Hey,

i had found a statement of the repository maintainer a few months ago which i had quoted in another thread below: