Groups showing correct number of users but no list


#1

Steps to reproduce

  1. Create User
  2. Add to Group
  3. Go to group

Expected behaviour

Group updates with correct number of users on the right of the group name.
On loading group the list is updated with correct users.

Actual behaviour

Group updates with correct number of users on the right of group name.
On loading group the list is blank showing no users.

Server configuration

Ubuntu 18.04

Apache 2

MySQL

7.2

10.0.8

Fresh Install

OwnCloud

Technical information
=====================
The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results
=======
- core
	- INVALID_HASH
		- .htaccess
	- FILE_MISSING
		- .user.ini

Raw output
==========
Array
(
    [core] => Array
        (
            [INVALID_HASH] => Array
                (
                    [.htaccess] => Array
                        (
                            [expected] => c00197d1a4d7a1db5bf43849acd10d2d7813705463ba02fe540b5d05328dcf078456e55dcd0450bb884a85bf25c66a596cdcf9108d26ba44d2287a35de26d72b
                            [current] => cf83e1357eefb8bdf1542850d66d8007d620e4050b5715dc83f4a921d36ce9ce47d0d13c5d85f2b0ff8318d2877eec2f63b931bd47417a81a538327af927da3e
                        )

                )

            [FILE_MISSING] => Array
                (
                    [.user.ini] => Array
                        (
                            [expected] => 0a557e3cdca4c2e3675deed761d79d109011dcdebbd9c7f6429f1d3476938ec95729543d7384651d1d0c48e26c5024cc5f517445920915a704ea748bdb903c5f
                            [current] => 
                        )

                )

        )

)

<?php
$CONFIG = array (
'instanceid' => #
'passwordsalt' => #
'secret' => #
'trusted_domains' =>
array (
0 =>#
1 => #
2 =>#
),
'datadirectory' => '/var/www/html/data',
'overwrite.cli.url' => 'http://securetransfer',
'dbtype' => 'mysql',
'version' => '10.0.8.5',
'dbname' => 'owncloud',
'dbhost' => 'localhost',
'dbtableprefix' => 'oc_',
'mysql.utf8mb4' => true,
'dbuser' => 'oc_owncloud2',
'dbpassword' => 'UqAsznq1nL6Y2B4z0EpBou/lMZV+ei',
'logtimezone' => 'UTC',
'installed' => true,
'mail_domain' => 'berryworld.com',
'mail_from_address' => 'infrastructure',
'mail_smtpmode' => 'smtp',
'mail_smtpauthtype' => 'LOGIN',
'mail_smtpauth' => 1,
'mail_smtphost' => 'smtp.office365.com',
'mail_smtpport' => '587',
'mail_smtpsecure' => 'tls',
'mail_smtpname' => 'thomas.james@berryworld.com',
'mail_smtppassword' => #
'memcache.local' => '\OC\Memcache\Redis',
'filelocking.enabled' => 'true',
'memcache.distributed' => '\OC\Memcache\Redis',
'memcache.locking' => '\OC\Memcache\Redis',
'redis' =>
array (
'host' => 'localhost',
'port' => 6379,
'timeout' => 0,
'dbindex' => 0,
),
);

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

None

Yes

None

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

#2

Hi,

Just created 2 users and put them in 1 group

Please copy the questions you are giving the answers to. I can't figure out what "none, yes, none" means.

Are you trying to create local groups and users or LDAP groups and users?


#3

Apologies Dmitry

I have a fresh installation using PHP 7.2, MySql and Ubuntu 18. When I created groups and assigned users to it, the number would update but opening the group showed nothing at all.

Having just gone back in, the numbers no longer show either. See the screenshot below. This is the same for both LDAP and Database added users.


#4

This is how our users are currently set up. There should be three users showing in the group (1 x Database, 2 x LDAP).


#5

Can you show me the users tab with "everyone"?


#6

I recreated the group with a different name using an alternate admin user. Still the same result.


#7

Okay, let me understand what you are trying to do.

You have domain users (LDAP) or local users. And you are trying to put them in local groups or domain (LDAP) groups?

Can you try the following:

create user1 and user2 - local users.

then create 2 groups -local groups. group1 and group2.

then put the user1 in group1 and user2 in group2 and click on the tabs.


#8

Created the test users (locally) with same result. They end up in the groups BUT the groups remain blank and the numbers also don't populate.


#9

FYI, I've logged on to the DB and found that it's throwing this error currently:


#10

I just noticed that I still have 16.04 for testing. I will test with 18.04 and get back to you.


#11

Thank you Dmitry, it's very much appreciated.


#12

I have since performed a complete, fresh install with the latest versions of Ubuntu, MySQL and PHP 7.2 and can confirm the issue is still there.

Looking at the PHPmyadmin, most of the tables are flagging the error about implementing countable objects. I have a feeling that if I reverted to an older version of PHP then this will resolve the issue.


#13

Can you provide the owncloud.log file after you encountered this error again?

By the way, Ubuntu 18.04 is not yet recommended for ownCloud

https://doc.owncloud.com/server/10.0/admin_manual/installation/system_requirements.html


#14

Hi Dmitry,

Please see attached: https://we.tl/vr2MTg1BOK

I would have used our system but it’s locked down for internal testing currently and the upload on this reports its bigger than 3mb (it isn’t…).

Tom


#15

I just had a quick look, but you have many errors in your log.

What I have found so far - encryption - maybe you want to check that.

Impersonate and LDAP. Please check your configuration on those things.


#16

I have the same problem in WebUI that specific local groups doesn’t list their members. In my opinion it’s a problem with spaces/blanks in (local) group names. All my groups with one or more spaces/blanks in name are not list their members; all others do. The problem can also reproduce at command line:

For example there is a group with groupname it test an 2 members.
sudo -u www-data php occ group:list-members it test - return an error
sudo -u www-data php occ group:list-members “it test” - return the 2 group-member

With groupname in apostrophe the result is ok. Can I change the relevant command for WebUI request?

There is an another entry in this forum to a similar issue: Groups show number but not show list

With regards,
Lars


#17

You are correct. This is an issue with special characters in group name.

This has been identified as a bug and will be fixed.

Til then - the workaround is not to create groups with special characters in group name.


Groups show number but not show list
#18

Hi Dmitry,

what about the fix for the problem with special characters in group names? Until now, I can’t see a topic in the changelog. The problem still exists in 10.0.9.5.

With regards


#19

What happened was, the fix did not make it in the current release, and will be included in the next one.

I can, however, give you the patch to fix your problem. Would that be an option?


#20

Thanks for this offer. I only wanted to hear what’s up with the fix. I think I can wait for the next update und until there I use occ command as workaround.