Having a lot of problems!

installation

#1

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

Steps to reproduce
1. Install Ngnix, PhP, OwnCloud
2. Create SSL cert
3.

Expected behaviour
Tell us what should happen
I should be able to utilize the cloud when accessing my site.
Actual behaviour
Tell us what happens instead
I just get a blank screen. I should say when I did this the first time, it worked. I could use ownCloud. I could see and use my external drive. I pulled a file off and save it to another area to make sure everything was working. Once I left the owncloud, and came back, everything was gone. I have been unable to access it again. I'm doing this on the raspberry pi, so I formatted the SD card, reinstalled the os, and tried to duplicate but have no luck at all. I've been through about 7 different tutorials and can't get a working result. I keep getting my SSL refused by my browser, though I have a paid DNS through godaddy.
Server configuration
Operating system: Debian/Jessie
Web server:Nginx
Database:I don't know
PHP version:I don't know
ownCloud version (see ownCloud admin page): Latest
Updated from an older ownCloud or fresh install: New install
ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808):

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.

#2

So you manage to install ownCloud, then after some time, everything is gone? Then you installed it again, and the same things happened again? And where is the link with your SSL problem?

You have to tell us what you did, what exactly is not working and provide corresponding logfiles. "I didn't manage to drive the car, I tried so many tips but I never managed to get further than a couple of blocks. And the trunk is not properly closing. Please help me."


#3

Haha, yeah, it sounds a little ridiculous when you put it so plainly, but I don't even know where to begin in telling you what I did, or did not do.

I cannot repeat a successful install of the first time, even though I followed the same tutorial that worked the first time. Remember, I did I diskpart clean my SD drive, and reinstalled Raspian Jessie fresh, still no luck.

I'm hoping someone here can send me to a link where I can find a working tutorial owncloud, php, ngnix, or even another preferable option?


#4

If your tutorial worked the first time, it probably wasn't so wrong. Can you link it? There are hundreds and it's hard to check them all.

Can you place a test.php-file into /var/www/ or /var/www/html with this content:

<?php phpinfo(); ?>

and then open it via your browser. It should show you your php settings.


#5

It's not so easy to find a good tutorial. Without compiling nginx, or using php7, this one looks pretty straight forward:
http://blog.dical.org/2016/04/owncloud-9-0-1-on-raspberry-pi-3-step-by-step/

And use ownCloud 9.0.4.


#6

Thank you. I appreciate the help. I'll give this tutorial a shot!


#7

I was in the middle of a tutorial when I was given a link to the tutorial posted above. I'm trying to complete this one before moving onto the next.

My problem is that when I try to reload Nginx, I get this message:

[....] Reloading nginx configuration (via systemctl): nginx.serviceJob for nginx.service failed. See 'systemctl status nginx.service' and 'journalctl -xn' for details.

So I then check "systemctl status nginx.service" and I get this message:

● nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled)
Active: active (running) (Result: exit-code) since Sat 2016-08-27 11:41:08 CDT; 19h ago
Process: 12400 ExecReload=/usr/sbin/nginx -g daemon on; master_process on; -s reload (code=exited, status=1/FAILURE)
Main PID: 6730 (nginx)
CGroup: /system.slice/nginx.service
├─6730 nginx: master process /usr/sbin/nginx -g daemon on; master_process on;
├─6731 nginx: worker process
├─6732 nginx: worker process
├─6733 nginx: worker process
└─6734 nginx: worker process

Aug 27 17:23:02 toddspi systemd[1]: nginx.service: control process exited, code=exited status=1
Aug 27 17:23:02 toddspi systemd[1]: Reload failed for A high performance web server and a reverse proxy server.
Aug 27 21:45:00 toddspi systemd[1]: Reloading A high performance web server and a reverse proxy server.
Aug 27 21:45:00 toddspi nginx[10934]: nginx: [emerg] "keepalive_timeout" directive is duplicate in /etc/nginx/nginx.conf:39
Aug 27 21:45:00 toddspi systemd[1]: nginx.service: control process exited, code=exited status=1
Aug 27 21:45:00 toddspi systemd[1]: Reload failed for A high performance web server and a reverse proxy server.
Aug 28 07:19:53 toddspi systemd[1]: Reloading A high performance web server and a reverse proxy server.
Aug 28 07:19:53 toddspi nginx[12400]: nginx: [emerg] "keepalive_timeout" directive is duplicate in /etc/nginx/nginx.conf:39
Aug 28 07:19:53 toddspi systemd[1]: nginx.service: control process exited, code=exited status=1
Aug 28 07:19:53 toddspi systemd[1]: Reload failed for A high performance web server and a reverse proxy server.

Does someone have an idea about what's going on? I tried looking in "/etc/nginx/nginx.conf:39" to see if there was some duplicate code in there, but I can't get into the file.

Much Thanks!


#8

Hi,

for configuration support with nginx its recommended to jump over to https://nginx.org/en/support.html where you get support for that webserver.


#9

The duplicate entry could be in a different file within /etc/nginx. You can try to comment this one out and then try to start it again.