Help for the installation of the owncloud server in ubuntu mate 16.04


#1

Hello,

I can not access the owncloud server that I created on my computer missing some php package but, they are installed would you have a solution?

ii php 1:7.0+42-1~d all server-side, HTML-embedded script
ii php-common 1:42-1~dotde all Common files for PHP packages
ii php-curl 1:7.0+42-1~d all CURL module for PHP [default]
ii php-json 1:7.0+42-1~d all JSON module for PHP [default]
ii php-mbstring 1:7.0+42-1~d all MBSTRING module for PHP [default]
ii php-mcrypt 1:7.0+42-1~d all libmcrypt module for PHP [default
ii php-mysql 1:7.0+42-1~d all MySQL module for PHP [default]
ii php-xml 1:7.0+42-1~d all DOM, SimpleXML, WDDX, XML, and XS
ii php7.0 7.0.28-1~dot all server-side, HTML-embedded script
ii php7.0-bz2 7.0.28-1~dot i386 bzip2 module for PHP
ii php7.0-cli 7.0.28-1~dot i386 command-line interpreter for the
ii php7.0-common 7.0.28-1~dot i386 documentation, examples and commo
ii php7.0-curl 7.0.28-1~dot i386 CURL module for PHP
ii php7.0-fpm 7.0.28-1~dot i386 server-side, HTML-embedded script
ii php7.0-json 7.0.28-1~dot i386 JSON module for PHP
ii php7.0-mbstrin 7.0.28-1~dot i386 MBSTRING module for PHP
ii php7.0-mcrypt 7.0.28-1~dot i386 libmcrypt module for PHP
ii php7.0-mysql 7.0.28-1~dot i386 MySQL module for PHP
ii php7.0-opcache 7.0.28-1~dot i386 Zend OpCache module for PHP
ii php7.0-readlin 7.0.28-1~dot i386 readline module for PHP
ii php7.0-xml 7.0.28-1~dot i386 DOM, SimpleXML, WDDX, XML, and XS

can you help me? thinks


#2

Hi,

could this be it?

https://central.owncloud.org/t/php-module-intl-not-installed/12442/3?u=dmitry

Maybe the PHP version on the command line is not the same PHP version running by Apache?

credits to @tom42


#3

i installed the php7.0-intl and made a reboot of the apache server i have more than that error now


#4

I think your webserver is either still running PHP 5.something or the modules are just not enabled correctly in your PHP environment.


#5

ok but i don't have a paquet php5 installed in my pc but y have this message when i try to install the php module missing

The following packages contain unmet dependencies:
php7.0-gd: depends: libjpeg62-turbo (> = 1.3.1) but it is not installable
php7.0-intl: Depends on: libicu52 (> = 52 ~ m1-1 ~) but it is not installable
php7.0-zip: Depends: libzip2 (> = 0.11.2) but it is not installable
E: Unable to fix problems, defective packages are in "keep as is" mode.


#6

I'm not sure but i think it would be better if you ask for help with such Ubunutu / installation problems at forums where you can find more people using Ubuntu. To me this looks more like a problem unrelated to ownCloud.